Bug 1300433 - Pacemaker pcs command is not accepting domain suffix for no_proxy env. variable
Pacemaker pcs command is not accepting domain suffix for no_proxy env. variable
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ruby (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Pavel Valena
Iveta Wiedermann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-20 14:30 EST by Ryan Howe
Modified: 2016-11-04 02:16 EDT (History)
8 users (show)

See Also:
Fixed In Version: ruby-2.0.0.648-26.el7
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
: 1384810 1384838 (view as bug list)
Environment:
Last Closed: 2016-11-04 02:16:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 6 Vít Ondruch 2016-02-12 04:54:10 EST
Well, the no_proxy implementation is not really full featured. Here is a list of upstream RFE tickets which might be relevant:

https://bugs.ruby-lang.org/issues/10251
https://bugs.ruby-lang.org/issues/8317 (this included patch, you probably want to test it if it helps)
https://bugs.ruby-lang.org/issues/12062
Comment 7 Vít Ondruch 2016-05-24 11:41:41 EDT
So it seems upstream applied the patches from

https://bugs.ruby-lang.org/issues/8317
https://bugs.ruby-lang.org/issues/12062

as well. I requested backport to older versions as well:

https://bugs.ruby-lang.org/issues/12421

Would you mind to test which of the patches resolves the issues you describe above?
Comment 14 errata-xmlrpc 2016-11-04 02:16:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2422.html

Note You need to log in before you can comment on or make changes to this bug.