Bug 1300459 - atomic v1.8.0 makes egg-info a file v/s a directory in v1.6
atomic v1.8.0 makes egg-info a file v/s a directory in v1.6
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: atomic (Show other bugs)
7.2
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Brent Baude
atomic-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-20 17:00 EST by Lokesh Mandvekar
Modified: 2016-03-31 19:25 EDT (History)
3 users (show)

See Also:
Fixed In Version: atomic-1.8-5.git1bc3814
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-31 19:25:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lokesh Mandvekar 2016-01-20 17:00:35 EST
Description of problem:

$ rpm -q atomic
atomic-1.6-6.gitca1e384.el7.x86_64

$ ls /usr/lib/python2.7/site-packages/atomic-1.6-py2.7.egg-info/
dependency_links.txt  PKG-INFO	requires.txt  SOURCES.txt  top_level.txt



on updating to 1.8.0...

$ rpm -q atomic
atomic-1.8-4.git958d939.el7.x86_64

$ cat /usr/lib/python2.7/site-packages/atomic-1.8-py2.7.egg-info 
Metadata-Version: 1.0
Name: atomic
Version: 1.8
Summary: UNKNOWN
Home-page: UNKNOWN
Author: Daniel Walsh
Author-email: dwalsh@redhat.com>
License: UNKNOWN
Description: UNKNOWN
Platform: UNKNOWN


Version-Release number of selected component (if applicable): atomic-1.8-4.git958d939.el7.x86_64

This causes the rpmdiff error here: https://errata.devel.redhat.com/rpmdiff/show/137813?result_id=3559740
Comment 2 Daniel Walsh 2016-01-21 10:14:54 EST
Brent could you take a look at this?
Comment 9 Daniel Walsh 2016-01-22 11:46:55 EST
Lets remove it and leave it in site-library for now. Allowing users to do a

import Atomic

Is not a bad thing.
Comment 10 Daniel Walsh 2016-01-22 12:30:04 EST
Here is a patch to remove it after it is installed.

https://github.com/projectatomic/atomic/pull/291

I tried to figure out a way to simply not install it in the first place, but I did not find anything obvious. If any setup.py experts have a way to tell setup not to create the file, that would be a better solution.
Comment 12 Alex Jia 2016-01-27 00:36:01 EST
The egg-info file has been removed from atomic-1.8-6.

[cloud-user@atomic-00 ~]$ rpm -q atomic
atomic-1.8-6.git1bc3814.el7.x86_64
[cloud-user@atomic-00 ~]$ ls /usr/lib/python2.7/site-packages/atomic-1.8-py2.7.egg-info
ls: cannot access /usr/lib/python2.7/site-packages/atomic-1.8-py2.7.egg-info: No such file or directory
Comment 13 Lokesh Mandvekar 2016-01-27 00:55:31 EST
(In reply to Alex Jia from comment #12)
> The egg-info file has been removed from atomic-1.8-6.
> 
> [cloud-user@atomic-00 ~]$ rpm -q atomic
> atomic-1.8-6.git1bc3814.el7.x86_64
> [cloud-user@atomic-00 ~]$ ls
> /usr/lib/python2.7/site-packages/atomic-1.8-py2.7.egg-info
> ls: cannot access
> /usr/lib/python2.7/site-packages/atomic-1.8-py2.7.egg-info: No such file or
> directory

yes, that's expected behavior as per the latest commit
Comment 14 Alex Jia 2016-01-27 01:43:19 EST
(In reply to Lokesh Mandvekar from comment #13)
> > /usr/lib/python2.7/site-packages/atomic-1.8-py2.7.egg-info: No such file or
> > directory
> 
> yes, that's expected behavior as per the latest commit

Yes, I see, is it enough for your? need I to double verify it use rpmdiff/rpmdiff-cli? it seems we only have a rpmdiff for el7sed version w/o single el7 version.
Comment 15 Alex Jia 2016-02-01 00:24:28 EST
Per comment 12 and comment 13, move the bug to VERIFIED status.
Comment 17 errata-xmlrpc 2016-03-31 19:25:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0527.html

Note You need to log in before you can comment on or make changes to this bug.