Bug 1300462 - [RFE] Errata needs to indicate when a reboot of the host is required
[RFE] Errata needs to indicate when a reboot of the host is required
Status: CLOSED DUPLICATE of bug 1240472
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Errata Management (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
: FutureFeature
Depends On:
Blocks: 260381 GSS_Sat6Beta_Tracker/GSS_Sat6_Tracker
  Show dependency treegraph
 
Reported: 2016-01-20 17:28 EST by David Caplan
Modified: 2016-02-11 11:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-11 11:31:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Caplan 2016-01-20 17:28:17 EST
Description of problem:

In Satellite 6 there is no indication in the Errata system when a reboot is necessary to complete the update. 


Version-Release number of selected component (if applicable):


How reproducible:

Arriving Errata that require rebooting the host are shown in the errata notification but there is no signal or indication or notification that a reboot is required for affected hosts. With the arrival of Satellite 6.2 we need to integrate this capability into Errata notification (in the UX, the API, the CLI, and Email) and we need to add a hook into the remote execution templates for updates to trigger a reboot after the update is applied.

It would also be necessary to add a reboot directive to the Katello Agent for customer use cases that do not allow SSH driven operations (no push from Satellite). The UX, API, and CLI need to have this option exposed to complete the errata update.


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
When Errata arrives (after a content sync), if a reboot is required to complete the update of said errata, there are multiple indications delivered to the Satellite Systems operator:
1. The UI indicates that reboot is required
2. The Email notification to the registered recipients indicates that a reboot is required for a given errata
3. Hammer and API commands that display errata also depict indications that a reboot is required
4. The update process through goferd (initiated from the UX, API, and CLI) provide a reboot after update option
5. The satellite 6.2 remote execution feature will automatically detect reboot indications for arriving errata and will account for the reboot action in the errata update template.


Additional info:
Comment 2 Bryan Kearney 2016-02-11 11:31:36 EST

*** This bug has been marked as a duplicate of bug 1240472 ***

Note You need to log in before you can comment on or make changes to this bug.