Bug 1300466 - ntp server is not configured on controller nodes even though --ntp-server was specified
Summary: ntp server is not configured on controller nodes even though --ntp-server was...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: 10.0 (Newton)
Assignee: Jiri Stransky
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-20 23:09 UTC by David Hill
Modified: 2016-12-14 15:21 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:21:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description David Hill 2016-01-20 23:09:07 UTC
Description of problem:
ntp server is not configured on controller nodes even though --ntp-server was specified but it is configured on computes.  This has for effect that controller time might skew and generate issues

Version-Release number of selected component (if applicable):


How reproducible:
RHOSP 7.0 and RHOSP 8.0


Steps to Reproduce:
1. Deploy the overcloud with --ntp-server
2. Watch for /etc/ntp.conf
3.

Actual results:
Not configured on controllers

Expected results:
Should be configured everywhere and at this point, why not configure ntp.conf on controller to syn with external source and sync all computes with the controllers as source?

Additional info:

Comment 4 Mike Burns 2016-04-07 21:03:37 UTC
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.

Comment 6 Gregory Charot 2016-09-23 18:00:33 UTC
Same issue on current OSP10 last rhos release, on all nodes not only the controllers.

Tried successfully on OSP9 though.

Comment 8 Gregory Charot 2016-10-11 10:36:52 UTC
Used last rhos-release puddle, seems fixed now.

Deployed with --ntp-server 10.16.255.1

[root@overcloud-controller-0 ~]# grep server /etc/ntp.conf
server 10.16.255.1

[root@overcloud-controller-0 ~]# ntpq -p
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
 10.16.255.1     .XFAC.          16 u   68   64    0    0.000    0.000   0.000

Cheers,
Greg

Comment 9 Marius Cornea 2016-11-22 09:23:31 UTC
On OSP10:

[root@overcloud-controller-0 heat-admin]# grep ^server /etc/ntp.conf 
server clock.redhat.com
server clock.redhat.com

which matches the NTP servers set in an environment file:

[stack@undercloud-0 ~]$ grep NtpServer network-environment.yaml 
  NtpServer: ["clock.redhat.com","clock.redhat.com"]

Comment 10 Gregory Charot 2016-11-22 09:36:37 UTC
Verified with --ntp-server as well. Any specific reason for not using chronyd ?

Comment 13 errata-xmlrpc 2016-12-14 15:21:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.