Bug 1300562 - Mitaka - Could not find resource 'Service[mysqld]' for relationship from 'File[mysql-config-file]'
Summary: Mitaka - Could not find resource 'Service[mysqld]' for relationship from 'Fil...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RDO
Classification: Community
Component: openstack-puppet-modules
Version: trunk
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Milestone3
: trunk
Assignee: Lukas Bezdicka
QA Contact: yeylon@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-21 07:18 UTC by Michele Baldessari
Modified: 2016-04-18 07:00 UTC (History)
6 users (show)

Fixed In Version: openstack-puppet-modules-8.0.0a0-11.g927ae19.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-30 23:02:33 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gerrithub.io 260621 0 None None None 2016-01-22 13:50:59 UTC
Gerrithub.io 260631 0 None None None 2016-01-22 13:51:55 UTC

Description Michele Baldessari 2016-01-21 07:18:53 UTC
Description of problem:
When trying to deploy mitaka via RDO-manager with HA I get the error in the subject.
The reason is that the package in trunk openstack-puppet-modules-8.0.0a0-6.gfa42243.el7.centos.noarch does not have the following upstream
commit:
https://github.com/puppetlabs/puppetlabs-mysql/commit/1cfddec3ff2baa12e5eb87606712f33a2b2b0473

Once that commit is added to the images, everything is dandy again

Version-Release number of selected component (if applicable):
openstack-puppet-modules-8.0.0a0-6.gfa42243.el7.centos.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy via -e /usr/share/openstack-tripleo-heat-templates/environments/puppet-pacemaker.yaml using RDO-Manager

Comment 1 John Trowbridge 2016-01-21 14:02:38 UTC
I can confirm this issue happens whenever the puppet-pacemaker environment is used. Since the fix is merged in puppetlabs-mysql, it should make it into the next openstack-puppet-modules rpm.

Comment 2 Alan Pevec 2016-01-22 00:09:57 UTC
Is OPM master going to be rebased or this specific patch added temporarily?

Comment 3 Jason Guiditta 2016-01-22 13:09:09 UTC
We are doing a rebase today anyway, so we can include this update


Note You need to log in before you can comment on or make changes to this bug.