Bug 1300562 - Mitaka - Could not find resource 'Service[mysqld]' for relationship from 'File[mysql-config-file]'
Mitaka - Could not find resource 'Service[mysqld]' for relationship from 'Fil...
Product: RDO
Classification: Community
Component: openstack-puppet-modules (Show other bugs)
Unspecified Unspecified
unspecified Severity high
: Milestone3
: trunk
Assigned To: Lukas Bezdicka
Depends On:
  Show dependency treegraph
Reported: 2016-01-21 02:18 EST by Michele Baldessari
Modified: 2016-04-18 03:00 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-8.0.0a0-11.g927ae19.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-03-30 19:02:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
Gerrithub.io 260621 None None None 2016-01-22 08:50 EST
Gerrithub.io 260631 None None None 2016-01-22 08:51 EST

  None (edit)
Description Michele Baldessari 2016-01-21 02:18:53 EST
Description of problem:
When trying to deploy mitaka via RDO-manager with HA I get the error in the subject.
The reason is that the package in trunk openstack-puppet-modules-8.0.0a0-6.gfa42243.el7.centos.noarch does not have the following upstream

Once that commit is added to the images, everything is dandy again

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Deploy via -e /usr/share/openstack-tripleo-heat-templates/environments/puppet-pacemaker.yaml using RDO-Manager
Comment 1 John Trowbridge 2016-01-21 09:02:38 EST
I can confirm this issue happens whenever the puppet-pacemaker environment is used. Since the fix is merged in puppetlabs-mysql, it should make it into the next openstack-puppet-modules rpm.
Comment 2 Alan Pevec 2016-01-21 19:09:57 EST
Is OPM master going to be rebased or this specific patch added temporarily?
Comment 3 Jason Guiditta 2016-01-22 08:09:09 EST
We are doing a rebase today anyway, so we can include this update

Note You need to log in before you can comment on or make changes to this bug.