Bug 1300574 - Libvirt does not support virtualHW.version 11 of esx guest
Libvirt does not support virtualHW.version 11 of esx guest
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.8
x86_64 Unspecified
medium Severity low
: rc
: ---
Assigned To: Martin Kletzander
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-21 03:05 EST by tingting zheng
Modified: 2016-05-10 15:25 EDT (History)
4 users (show)

See Also:
Fixed In Version: libvirt-0.10.2-57.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 15:25:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tingting zheng 2016-01-21 03:05:25 EST
Description of problem:
libvirt does not support virtualHW.version 11

Version-Release number of selected component (if applicable):
libvirt-0.10.2-56.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Prepare a VM from an esx host that has hardware version 11.
2.Use virsh to connect the esx host.
# virsh -c esx://10.66.144.40/?no_verify=1
Enter username for 10.66.144.40 [root]: 
Enter root's password for 10.66.144.40: 
Welcome to virsh, the virtualization interactive terminal.

Type:  'help' for help with commands
       'quit' to quit

virsh # list --all
 Id    Name                           State
----------------------------------------------------
 1     win2012R2-vcenter              running
 43    VMware-vcenter-server-app      running
 -     app_vcenter600                 shut off
 -     Auto-esx6.0-win7-efi           shut off
 -     bug1260689-win2008R2-GPO-Macfee shut off
 -     esx6.0-rhel5.11-i386           shut off
 -     esx6.0-rhel5.11-x86_64         shut off

3.Use virsh dumpxml to get the xml of the vm with virtualHW.version 11.
virsh # dumpxml test-rhel6u6-x64
error: internal error Expecting VMX entry 'virtualHW.version' to be 4, 7, 8, 9 or 10 but found 11


Actual results:
As described.

Expected results:
Libvirt support dumpxml for esx guest with virtualHW.version 11.

Additional info:
Comment 2 Jaroslav Suchanek 2016-01-21 09:15:04 EST
Maybe this should help to sort it out "forever"?

commit 0e4370eddf822fcdd2ed60d7326b2191e1fd948d
Author: Matthias Bolte <matthias.bolte@googlemail.com>
Date:   Sat May 10 16:36:56 2014 +0200

    vmx: Relax virtualHW.version check
    
    The original implementation of the VMX config parser assumed that the
    virtualHW.version would have more influence on the content of the VMX
    file than it actually seems to have. It started with accepting only
    version 4. Additonal versions were added later without any additional
    changes in the parser itself. This suggests that the influence of the
    virtualHW.version on the content and format of the VMX file is small
    or non-existent.
    
    The parser worked without any changes across several virtualHW and
    vSphere versions. So instead of adding new virtualHW.version values to
    the parser as they come along, or adding an extra flag to allow unknown
    virtualHW.version values just relax the check to require version 4 or
    later.
Comment 5 mxie@redhat.com 2016-02-17 01:16:07 EST
I can reproduced the bug with build:
libvirt-0.10.2-56.el6.x86_64

Try to verfiy the bug with build:
libvirt-0.10.2-57.el6.x86_64


Steps:
1.Prepare a VM from an esx host that has hardware version 11.
2.Use virsh to connect the esx host.
# virsh -c esx://10.66.144.40/?no_verify=1
Enter username for 10.66.144.40 [root]: 
Enter root's password for 10.66.144.40: 
Welcome to virsh, the virtualization interactive terminal.

Type:  'help' for help with commands
       'quit' to quit

virsh # list --all
 Id    Name                           State
----------------------------------------------------
 1     win2012R2-vcenter              running
 -     rhel5.11-mxie                  shut off
 -     rhel6.7-mxie                   shut off
 -     test-juzhou                    shut off
 -     test-rhel6u6-x64               shut off

3.Use virsh dumpxml to get the xml of the vm with virtualHW.version 11.
virsh # dumpxml test-rhel6u6-x64
<domain type='vmware'>
  <name>test-rhel6u6-x64</name>
  <uuid>421c4727-c7aa-8bfc-1557-b5ac56e75608</uuid>
  <memory unit='KiB'>1048576</memory>
  <currentMemory unit='KiB'>1048576</currentMemory>
  <vcpu placement='static'>1</vcpu>
  <cputune>
    <shares>1000</shares>
  </cputune>
  <os>
    <type arch='x86_64'>hvm</type>
  </os>
  <clock offset='utc'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>destroy</on_crash>
  <devices>
    <disk type='file' device='disk'>
      <source file='[datastore1] test-rhel6u6-x64/test-rhel6u6-x64.vmdk'/>
      <target dev='sda' bus='scsi'/>
      <address type='drive' controller='0' bus='0' target='0' unit='0'/>
    </disk>
    <controller type='scsi' index='0' model='vmpvscsi'/>
    <interface type='bridge'>
      <mac address='00:50:56:9c:58:9c'/>
      <source bridge='VM Network'/>
      <model type='vmxnet3'/>
    </interface>
    <video>
      <model type='vmvga' vram='8192'/>
    </video>
  </devices>
</domain>

Result now:
Libvirt support dumpxml for esx guest with virtualHW.version 11 now

So move the bug from ON_QA to VERIFIED
Comment 7 errata-xmlrpc 2016-05-10 15:25:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0738.html

Note You need to log in before you can comment on or make changes to this bug.