This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1300580 - Backport: Tracker for IPV6 router is not working with VRRP
Backport: Tracker for IPV6 router is not working with VRRP
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: z4
: 7.0 (Kilo)
Assigned To: Nir Magnezi
Toni Freger
: ZStream
: 1310783 (view as bug list)
Depends On: 1222775 1300584
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-21 03:29 EST by Nir Magnezi
Modified: 2017-06-05 10:32 EDT (History)
13 users (show)

See Also:
Fixed In Version: openstack-neutron-2015.1.2-7.el7ost
Doc Type: Bug Fix
Doc Text:
Prior to this update, the fix for bug BZ#1215177 added the "garp_master_repeat 5" and "garp_master_refresh 10" options to Keepalived configuration. This resulted in two issues: 1. Keepalived never stopped broadcasting garps to the network. 2. Due to a Keepalived bug, instances lost their IPv6 default gateway. Consequently, it was determined that the IPv6 router was not working correctly with VRRP. This update resolves this issue by dropping the repeat and refresh Keepalived options. This fixes the IPv6 bug but re-introduces bug 1215177. To resolve this, use the delay option instead. As a result of this update, Keepalived sends a GARP when it transitions to MASTER, and then waits a number of seconds (determined by the delay option), and sends a GARP again. This uses an aggressive 'delay' setting to make sure that when the node boots, and the L3/L2 agents start, the L2 agent has enough time to wire the ports.
Story Points: ---
Clone Of: 1222775
Environment:
Last Closed: 2016-02-18 11:09:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
nmagnezi: needinfo-


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1357068 None None None 2016-01-21 03:29 EST
Launchpad 1520517 None None None 2016-01-21 03:29 EST
OpenStack gerrit 270653 None None None 2016-01-21 03:29 EST

  None (edit)
Comment 2 Ofer Blaut 2016-01-24 05:29:54 EST
1. created network with ipv6 
neutron subnet-create net201 21.0.0.0/24 --name subnet-21-id-201 --dns_nameservers list=true 10.35.28.28
--name v6-network --ip-version 6 --ipv6-ra-mode slaac  --ipv6-address-mode slaac
neutron subnet-create net201 3001::10/64 --name v6-network --ip-version 6 --ipv6-ra-mode slaac  --ipv6-address-mode slaac
neutron router-create router1
neutron router-interface-add router1 subnet-21-id-201
neutron router-interface-add router1 v6-network


2. booted a VM and ssh via IPv4
3. check default gw ip - neutron router-port-list router1

4. ping  the router ipv6 address
5. checked agent host the router 
6. kill that host  echo "b" > /proc/sysrq-trigger 
7. pings from VM must keep running 


openstack-neutron-2015.1.2-7.el7ost.noarch




[stack@instack ~]$ 
[stack@instack ~]$ neutron l3-agent-list-hosting-router router1
+--------------------------------------+------------------------------------+----------------+-------+----------+
| id                                   | host                               | admin_state_up | alive | ha_state |
+--------------------------------------+------------------------------------+----------------+-------+----------+
| 75b45a8c-6257-4cc8-adf5-e89d55fb236c | overcloud-controller-1.localdomain | True           | :-)   | standby  |
| bc6f1bc2-c5c6-4353-84e3-38b4556893bf | overcloud-controller-0.localdomain | True           | :-)   | standby  |
| ca3227f1-d0bf-4f4e-9e88-91560789fe61 | overcloud-controller-2.localdomain | True           | :-)   | active   |
+--------------------------------------+------------------------------------+----------------+-------+----------+
[stack@instack ~]$ 
[stack@instack ~]$ 
[stack@instack ~]$ neutron l3-agent-list-hosting-router router1
+--------------------------------------+------------------------------------+----------------+-------+----------+
| id                                   | host                               | admin_state_up | alive | ha_state |
+--------------------------------------+------------------------------------+----------------+-------+----------+
| 75b45a8c-6257-4cc8-adf5-e89d55fb236c | overcloud-controller-1.localdomain | True           | :-)   | active   |
| bc6f1bc2-c5c6-4353-84e3-38b4556893bf | overcloud-controller-0.localdomain | True           | :-)   | standby  |
| ca3227f1-d0bf-4f4e-9e88-91560789fe61 | overcloud-controller-2.localdomain | True           | :-)   | active   |
+--------------------------------------+------------------------------------+----------------+-------+----------+
Comment 5 errata-xmlrpc 2016-02-18 11:09:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0260.html
Comment 6 Assaf Muller 2017-06-05 10:32:31 EDT
*** Bug 1310783 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.