Bug 1300589 - "--recommended" option doesn't work for "part /boot"
"--recommended" option doesn't work for "part /boot"
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity urgent
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-21 03:57 EST by Zhang Yi
Modified: 2017-12-06 07:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 07:41:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhang Yi 2016-01-21 03:57:48 EST
Description of problem:
"--recommended" option doesn't work for "part /boot"

Version-Release number of selected component (if applicable):
anaconda installer init version 13.21.243

How reproducible:
100%

Steps to Reproduce:
1. execute job https://beaker.engineering.redhat.com/jobs/1197563
2. Wait for installation
3.

Actual results:
Below configure doesn't work on RHEL6.8, but it works on RHEL7.2
part raid.01 --grow
part /boot --asprimary --fstype="ext4" --recommended

After change as below, it works on RHEL6.8
part raid.01 --size=1 --grow
part /boot --asprimary --fstype="ext4" --size=512

Expected results:


Additional info:
The following error was found while parsing the kickstart   
│     
│ configuration file:    
│     
│    
│      
│ The following problem occurred on line 17 of the kickstart file: │      
│    
│      
│ Partition requires a size specification
Comment 2 David Lehman 2016-01-21 11:05:33 EST
The --recommended option has never been meaningful for anything other than swap devices. The reason you don't get an error in RHEL-7 is that there is a default size of 500 MiB for new partitions there. This is not the case in RHEL-6, which is extremely unlikely to change.
Comment 3 Zhang Yi 2016-01-21 22:00:27 EST
(In reply to David Lehman from comment #2)
> The --recommended option has never been meaningful for anything other than
> swap devices. The reason you don't get an error in RHEL-7 is that there is a
> default size of 500 MiB for new partitions there. This is not the case in
> RHEL-6, which is extremely unlikely to change.

Thanks David.
How about below:

RHEL7 works with "part raid.01 --grow"

RHEL6.8 doesn't work with it, but works with below
part raid.01 --size=1 --grow

Are we planning to change them same with RHEL7?
Comment 4 David Lehman 2016-01-26 08:22:21 EST
There are no plans to change RHEL7 to match RHEL6 in this regard.
Comment 6 Jan Kurik 2017-12-06 07:41:43 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.