This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1300600 - tests/bugs/quota/bug-1049323.t fails in fedora
tests/bugs/quota/bug-1049323.t fails in fedora
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tests (Show other bugs)
3.7.7
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Manikandan
: EasyFix, Triaged
Depends On: 1297740
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-21 04:26 EST by Manikandan
Modified: 2016-09-20 00:29 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1297740
Environment:
Last Closed: 2016-02-16 03:59:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manikandan 2016-01-21 04:26:03 EST
+++ This bug was initially created as a clone of Bug #1297740 +++

Description of problem:
Test file tests/bugs/quota/bug-1049323.t fails in fedora. The test that fails is 
"EXPECT "0"  get_aux" where we return 0 when an auxiliary mount is created. In get_aux function we grep for "/var/run/gluster/<volname> to check if volume is up and return 0; In fedora, auxiliary mount is created on /run/gluster/<volname> and it causes the test to fail.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:
Test is not passing in Fedora

Expected results:
Test should pass in Fedora

Additional info:
The fix is simple. In get_aux function, grep for substring, "/run/gluster/<volname>" and it will pass both on Fedora and CentOS as well

--- Additional comment from Vijay Bellur on 2016-01-12 06:16:37 EST ---

REVIEW: http://review.gluster.org/13228 (tests/quota : fix failing test on auxiliary mount point) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-12 07:09:30 EST ---

REVIEW: http://review.gluster.org/13228 (tests/quota : fix failing test on auxiliary mount point) posted (#2) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-12 13:26:17 EST ---

COMMIT: http://review.gluster.org/13228 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit ae165bd6d7c3a0130984cbd927be318146c7bbdd
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Tue Jan 12 16:38:27 2016 +0530

    tests/quota : fix failing test on auxiliary mount point
    
    In test file tests/bugs/quota/bug-1049323.t, test "EXPECT "0" get_aux"
    fails in Fedora.
    
    In get_aux function we grep for "/var/run/gluster/<volname>" to check
    if auxiliary mount point is created and we return 0 on success else we
    return 1. In fedora, auxiliary mount point is created on
    "/run/gluster/<volname>". So it fails on Fedora.
    
    The patch fixes it by just grepping for "/run/gluster/<volname>".
    
    Change-Id: Icb59395df4a98109eaa8199cbdbdedcd1cbef27a
    BUG: 1297740
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/13228
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Comment 1 Vijay Bellur 2016-01-21 04:35:33 EST
REVIEW: http://review.gluster.org/13273 (tests/quota : fix failing test on auxiliary mount point) posted (#1) for review on release-3.7 by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 2 Vijay Bellur 2016-01-28 00:16:10 EST
COMMIT: http://review.gluster.org/13273 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit a816cc5124951a2cbe57d2bd95b6690e766c57a7
Author: Manikandan Selvaganesh <mselvaga@redhat.com>
Date:   Tue Jan 12 16:38:27 2016 +0530

    tests/quota : fix failing test on auxiliary mount point
    
    In test file tests/bugs/quota/bug-1049323.t, test "EXPECT "0" get_aux"
    fails in Fedora.
    
    In get_aux function we grep for "/var/run/gluster/<volname>" to check
    if auxiliary mount point is created and we return 0 on success else we
    return 1. In fedora, auxiliary mount point is created on
    "/run/gluster/<volname>". So it fails on Fedora.
    
    The patch fixes it by just grepping for "/run/gluster/<volname>".
    
            Backport of http://review.gluster.org/#/c/13228/
    
    > Change-Id: Icb59395df4a98109eaa8199cbdbdedcd1cbef27a
    > BUG: 1297740
    > Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    > Reviewed-on: http://review.gluster.org/13228
    > Reviewed-by: Niels de Vos <ndevos@redhat.com>
    > Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    
    Change-Id: Icb59395df4a98109eaa8199cbdbdedcd1cbef27a
    BUG: 1300600
    Signed-off-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-on: http://review.gluster.org/13273
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 3 Kaushal 2016-04-19 03:52:59 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.