Bug 130063 - CAN-2004-0755 ruby insecure file permissions
CAN-2004-0755 ruby insecure file permissions
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Bill Huang
: Security
Depends On:
  Show dependency treegraph
Reported: 2004-08-16 16:17 EDT by Josh Bressers
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 1.8.1-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-15 04:56:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Josh Bressers 2004-08-16 16:17:19 EDT
From the Debian DSA

Andres Salomon no ticed a problem in the CGI session management of
Ruby, an object-oriented scripting language.  CGI::Session's FileStore
(and presumably PStore, but not in Debian woody) implementations store
session information insecurely.  They simply create files, ignoring
permission issues.  This can lead an attacker who has also shell
access to the webserver to take over a session.

This issue was reported to the Debian bug system

This issue should also affect FC1
Comment 1 Akira TAGOH 2004-08-18 06:44:04 EDT
this problem should be fixed in 1.8.1-6.

Note You need to log in before you can comment on or make changes to this bug.