Bug 1300630 - epel7 jctools FTBFS on aarch64
epel7 jctools FTBFS on aarch64
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: java-1.8.0-openjdk (Show other bugs)
7.2
aarch64 Linux
medium Severity medium
: rc
: ---
Assigned To: Andrew Haley
Lukas Zachar
:
Depends On:
Blocks: epel7aarch64 1297579 1313485 1277314
  Show dependency treegraph
 
Reported: 2016-01-21 05:10 EST by Yaakov Selkowitz
Modified: 2016-11-03 18:55 EDT (History)
5 users (show)

See Also:
Fixed In Version: java-1.8.0-openjdk-1.8.0.72-1.b15.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 18:55:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error report (43.93 KB, text/plain)
2016-01-21 05:10 EST, Yaakov Selkowitz
no flags Details

  None (edit)
Description Yaakov Selkowitz 2016-01-21 05:10:58 EST
Created attachment 1116890 [details]
error report

Attempting to build epel7 jctools on RHELSA 7.2 fails per the attached error report file.

As this is a noarch package and it does build on x86_64, this would appear to be a bug in the aarch64 port of java-1.8.0-openjdk.  Note that this also fails on Fedora aarch64, for which I will file a separate bug.
Comment 1 jiri vanek 2016-01-26 02:20:19 EST
Hi Andrew, this looks new after CPU.
Comment 3 Andrew Haley 2016-01-26 05:46:39 EST
I know what this bug is.

-XX:-TieredCompilation is a temporary workaround.
Comment 15 errata-xmlrpc 2016-11-03 18:55:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2139.html

Note You need to log in before you can comment on or make changes to this bug.