Bug 1300640 - spec: require python-six >= 1.9
Summary: spec: require python-six >= 1.9
Alias: None
Product: vdsm
Classification: oVirt
Component: Core
Version: ---
Hardware: Unspecified
OS: Unspecified
Target Milestone: ovirt-4.0.0-alpha
: 4.18.0
Assignee: Vinzenz Feenstra [evilissimo]
QA Contact: Lukas Svaty
Depends On:
TreeView+ depends on / blocked
Reported: 2016-01-21 10:39 UTC by Martin Perina
Modified: 2016-07-05 07:52 UTC (History)
8 users (show)

Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2016-07-05 07:52:54 UTC
oVirt Team: Infra
rule-engine: ovirt-4.0.0+
rule-engine: planning_ack+
danken: devel_ack+
rule-engine: testing_ack+

Attachments (Terms of Use)
engine & vdsm logs (400.82 KB, application/x-gzip)
2016-01-21 10:40 UTC, Martin Perina
no flags Details

System ID Private Priority Status Summary Last Updated
oVirt gerrit 53114 0 master MERGED Require python-six >= 1.9.0 2016-02-05 12:28:21 UTC

Description Martin Perina 2016-01-21 10:39:08 UTC
Description of problem:

When trying to add Centos 7 host to engine, ovirtmgmt bridge is not created and following exception appears in vdsm.log:

Traceback (most recent call last):
  File "/usr/share/vdsm/vdsm", line 151, in run
  File "/usr/share/vdsm/vdsm", line 101, in serve_clients
    from clientIF import clientIF  # must import after config is read
  File "/usr/share/vdsm/clientIF.py", line 31, in <module>
    from yajsonrpc.betterAsyncore import Reactor
  File "/usr/lib/python2.7/site-packages/yajsonrpc/betterAsyncore.py", line 25, in <module>
    from vdsm.sslcompat import sslutils
  File "/usr/lib/python2.7/site-packages/vdsm/sslcompat.py", line 23, in <module>
    from . import m2cutils as sslutils
  File "/usr/lib/python2.7/site-packages/vdsm/m2cutils.py", line 24, in <module>
    from six.moves import xmlrpc_client as xmlrpclib
ImportError: cannot import name xmlrpc_client

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Try to add new host into engine

Actual results:

Error adding new host in engine

Expected results:

Host added successfully

Additional info:

Comment 1 Martin Perina 2016-01-21 10:40:02 UTC
Created attachment 1116892 [details]
engine & vdsm logs

Comment 2 Piotr Kliczewski 2016-01-22 13:13:44 UTC
I attempted to reproduce it. I used a vm with installed "CentOS Linux release 7.2.1511 (Core)". I used: "yum install http://resources.ovirt.org/pub/yum-repo/ovirt-release-master.rpm" to get latest master vdsm. After running host deploy the host was 'Up'.

Please recheck whether it works for you with the latest vdsm.

Comment 3 Dan Kenigsberg 2016-01-23 15:27:59 UTC
Martin, which "six" version do you have installed? With


$ python -c 'from six.moves import xmlrpc_client as xmlrpclib'

is quitely successful.

Comment 4 Martin Perina 2016-01-25 09:07:55 UTC

the issue still remains even with latest master builds:


Here is version of python-six:


But when trying import, error appears:

python -c 'from six.moves import xmlrpc_client as xmlrpclib'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: cannot import name xmlrpc_client

Centos version is:
  CentOS Linux release 7.1.1503 (Core)

Comment 5 Piotr Kliczewski 2016-01-25 09:32:25 UTC
I can see that you have a bit older version of python-six.

I am using plain centos and on my vm there is installed from base repo.
I checked my f22 and there I have

It seems that we could explicitly require version of python-six in the spec.

Can you please update your OS and tell me whether the issue is still there?

Comment 6 Red Hat Bugzilla Rules Engine 2016-01-25 09:47:50 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

Comment 7 Martin Perina 2016-01-25 11:24:07 UTC
So after upgrading hosts to Centos 7.2 which contains python-six-1.9.0-2.el7.noarch the issue is fixed.

Is it worth to add version dependency for python-six >= 1.9.0 to vdsm or do we expect customers to run always latest version of Centos?

Comment 8 Dan Kenigsberg 2016-01-25 11:31:09 UTC
el>=7.2 is a requirement for ovirt>=3.6, but we tend to add a requirement when you see that missing it causes pain to users.

Comment 9 Lukas Svaty 2016-07-01 11:19:35 UTC
sanity only, verified in vdsm-4.18.999

Comment 10 Sandro Bonazzola 2016-07-05 07:52:54 UTC
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.