Bug 1300667 - iwl7260 wifi poor connection
iwl7260 wifi poor connection
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-21 06:59 EST by Timo Riikonen
Modified: 2016-09-27 09:56 EDT (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1087717
Environment:
Last Closed: 2016-09-27 09:56:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dmesg output (224.83 KB, text/plain)
2016-01-21 23:11 EST, Timo Riikonen
no flags Details

  None (edit)
Description Timo Riikonen 2016-01-21 06:59:03 EST
+++ This bug was initially created as a clone of Bug #1087717 +++

Description of problem:

When I use WPA2-AES secured 802.11n Wifi, connection breaks up sometimes so often that internet is in practice unusable. Sometimes not that often, but the speed is still always terrible.

It seems to me that this would be an old bug that has resurfaced again. I would be happy to this if this is correct or not, but I need instructions on how to do that.

I am using HP Envy with Intel 7260 WiFi adapter on latest Fedora release.
kernel.x86_64                  4.3.3-301.fc23 

sudo dnf list iwl7260-firmware
Installed Packages
iwl7260-firmware.noarch              1:25.30.13.0-60.fc23               @updates

How reproducible:
100%

According to previous defect texts version 22.1.7.0 is working well, but this command doesn't work: sudo dnf -y downgrade iwl7260-firmware:22.1.7.0
How can I downgrade the version?


See comments from bug 1087717 on how this was fixed the previous time.
Comment 1 Emmanuel Grumbach 2016-01-21 07:13:37 EST
This old firmware is no longer supported. Please attach the dmesg output.
Comment 2 Timo Riikonen 2016-01-21 23:11 EST
Created attachment 1117091 [details]
Dmesg output
Comment 3 Emmanuel Grumbach 2016-01-22 03:25:57 EST
Nothing I could get from the dmesg.

Can you please paste the output of

ethtool -i wlo1
Comment 4 Timo Riikonen 2016-01-23 22:35:12 EST
[timo@localhost Pictures]$ ethtool -i wlo1
driver: iwlwifi
version: 4.2.3-300.fc23.x86_64
firmware-version: 25.30.13.0
expansion-rom-version: 
bus-info: 0000:08:00.0
supports-statistics: yes
supports-test: no
supports-eeprom-access: no
supports-register-dump: no
supports-priv-flags: no
Comment 5 Emmanuel Grumbach 2016-01-23 23:10:36 EST
Can you please try to update to -16.ucode?

You can find it here.  https://git.kernel.org/cgit/linux/kernel/git/iwlwifi/linux-firmware.git/plain/iwlwifi-7260-16.ucode
Comment 6 Timo Riikonen 2016-01-24 08:06:01 EST
-16.code file has been copied to /usr/lib/firmware and OS has been rebooted. As it is the latest version I presume it is therefore in use.

This is new laptop. For couple of the first days even fetching google web page was sometimes too much load for the WiFi. But after that the ADSL/Wifi has been in less use and it can now takes hours in between clear Wifi errors.

I tried to find test & analysis tools but without success, so I suppose I need to test this second most recent version (17 was there as well).
Comment 7 Emmanuel Grumbach 2016-01-26 16:05:16 EST
Does it feel better with -16.ucode?
Comment 8 Timo Riikonen 2016-01-27 04:21:54 EST
No, it is still the same: works sometimes with varying quality.
Comment 9 Emmanuel Grumbach 2016-01-27 04:28:32 EST
Can you record tracing?

https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/debugging#tracing
Comment 10 Laura Abbott 2016-09-23 15:56:50 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 11 Timo Riikonen 2016-09-27 04:38:40 EDT
I found plenty of complaints on the WiFi router. We replaced that with another decide from a different manufacturer and this fixed the compatibility issues.
Comment 12 Timo Riikonen 2016-09-27 04:39:17 EDT
I found plenty of complaints on the WiFi router. We replaced that with another device from a different manufacturer and this fixed the compatibility issues.
Comment 13 Laura Abbott 2016-09-27 09:56:09 EDT
Thanks for letting us know. I'm going to close the bug for now. This bug can be reopened if the problem comes back.

Note You need to log in before you can comment on or make changes to this bug.