Bug 1300673 - [openstack-heat] heat-engine not starting on rhos8
[openstack-heat] heat-engine not starting on rhos8
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat (Show other bugs)
8.0 (Liberty)
Unspecified Linux
unspecified Severity high
: ga
: 8.0 (Liberty)
Assigned To: Zane Bitter
Amit Ugol
: Automation, AutomationBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-21 07:13 EST by Daniel Mellado
Modified: 2016-04-26 17:35 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-heat-5.0.1-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:25:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1518654 None None None 2016-01-21 07:13 EST

  None (edit)
Description Daniel Mellado 2016-01-21 07:13:46 EST
Description of problem:
When trying to start the heat-engine service several import issues show up in the log. This was discovered while trying to run the heat tempest tests in the following way:

python -m testtools.run tempest.api.orchestration.stacks.test_neutron_resources.NeutronResourcesTestJSON


After the fail, I checked the logs and found that in the heat-engine.log the following was showing:

./heat-engine.log:2016-01-21 04:58:56.799 29771 ERROR stevedore.extension ImportError: No module named croniter

Same happens for quite some modules, such as:

    manilaclient
    designateclient
    magnumclient.openstack.common.apiclient
    mistralclient.api
    zaqarclient

After restarting the heat services:

systemctl restart openstack-heat-api.service openstack-heat-api-cfn.service openstack-heat-engine.service

All the dependencies errors doesn't show up anymore and the test are passing without issue:

(.venv)[cloud-user@8usr0-dmellado-rh-pud-pksk-tester tempest-dir]$ python -m testtools.run tempest.api.orchestration.stacks.test_neutron_resources.NeutronResourcesTestJSON
Tests running...

Ran 6 tests in 49.119s
OK

Maybe there could be some kind of race condition or package issue for the heat python libraries?
Comment 2 Zane Bitter 2016-01-28 09:31:54 EST
This is already fixed and the patches are included in the build openstack-heat-5.0.1-1.el7ost
Comment 5 Zane Bitter 2016-01-28 15:57:47 EST
Ah, yes, we need to add a dependency on python-croniter. As a workaround for now you can just install it yourself.

(The others were fixed by disabling the plugins that we don't ship clients for. I'm not sure why you're not seeing the error messages again after a restart, but it's definitely not because of a race condition.)
Comment 7 errata-xmlrpc 2016-04-07 17:25:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.