Bug 1300678 - noVNC console doesn't work in IPv6 + SSL deployment
Summary: noVNC console doesn't work in IPv6 + SSL deployment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: y3
: 7.0 (Kilo)
Assignee: Marius Cornea
QA Contact: yeylon@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-21 12:39 UTC by Marius Cornea
Modified: 2016-04-18 07:13 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-heat-templates-0.8.6-111.el7ost
Doc Type: Bug Fix
Doc Text:
The VNC servers on Compute nodes would bind to IPv4 addresses only. Users could not access VNC consoles in an IPv6 environment since the Internal API network used IPv6 endpoints. The fix allows the VNC servers to bind on IPv6 addresses when deploying an IPv6 overcloud. Now users can access instances through VNC consoles in an IPv6 deployment.
Clone Of:
Environment:
Last Closed: 2016-02-18 16:50:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 270831 None None None 2016-01-21 14:44:27 UTC
Red Hat Product Errata RHBA-2016:0264 normal SHIPPED_LIVE Red Hat Enterprise Linux OSP 7 director Bug Fix Advisory 2016-02-18 21:41:29 UTC

Description Marius Cornea 2016-01-21 12:39:54 UTC
Description of problem:
noVNC console doesn't load in IPv6 + SSL deployment. The connection fails with:
Failed to connect to server (code: 1006)

Version-Release number of selected component (if applicable):
20 Jan puddle

How reproducible:
100%

Steps to Reproduce:
1. Deploy IPv6 + SSL enabled overcloud with 3 ctrls and 1 compute
2. Log in to Horizon
3. Create instance
4. Access its console

Actual results:
The connection fails with:
Failed to connect to server (code: 1006)

Expected results:
The VNC console shows up.

Comment 2 Marius Cornea 2016-01-22 13:29:44 UTC
openstack-tripleo-heat-templates-0.8.6-111.el7ost.noarch

Comment 4 errata-xmlrpc 2016-02-18 16:50:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0264.html


Note You need to log in before you can comment on or make changes to this bug.