Bug 1300678 - noVNC console doesn't work in IPv6 + SSL deployment
noVNC console doesn't work in IPv6 + SSL deployment
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity high
: y3
: 7.0 (Kilo)
Assigned To: Marius Cornea
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-21 07:39 EST by Marius Cornea
Modified: 2016-04-18 03:13 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.6-111.el7ost
Doc Type: Bug Fix
Doc Text:
The VNC servers on Compute nodes would bind to IPv4 addresses only. Users could not access VNC consoles in an IPv6 environment since the Internal API network used IPv6 endpoints. The fix allows the VNC servers to bind on IPv6 addresses when deploying an IPv6 overcloud. Now users can access instances through VNC consoles in an IPv6 deployment.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 11:50:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 270831 None None None 2016-01-21 09:44 EST

  None (edit)
Description Marius Cornea 2016-01-21 07:39:54 EST
Description of problem:
noVNC console doesn't load in IPv6 + SSL deployment. The connection fails with:
Failed to connect to server (code: 1006)

Version-Release number of selected component (if applicable):
20 Jan puddle

How reproducible:
100%

Steps to Reproduce:
1. Deploy IPv6 + SSL enabled overcloud with 3 ctrls and 1 compute
2. Log in to Horizon
3. Create instance
4. Access its console

Actual results:
The connection fails with:
Failed to connect to server (code: 1006)

Expected results:
The VNC console shows up.
Comment 2 Marius Cornea 2016-01-22 08:29:44 EST
openstack-tripleo-heat-templates-0.8.6-111.el7ost.noarch
Comment 4 errata-xmlrpc 2016-02-18 11:50:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0264.html

Note You need to log in before you can comment on or make changes to this bug.