Bug 1300707 - backport request for Bug 52315 - NULL pointer in log.c caused by ap_send_interim_response() in protocol.c
backport request for Bug 52315 - NULL pointer in log.c caused by ap_send_inte...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: httpd (Show other bugs)
6.7
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Web Stack Team
Martin Frodl
: ZStream
Depends On: 1298866
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-21 08:59 EST by Marcel Kolaja
Modified: 2016-02-09 03:45 EST (History)
8 users (show)

See Also:
Fixed In Version: httpd-2.2.15-47.el6_7.3
Doc Type: Bug Fix
Doc Text:
Previously, when writing an error message about an incorrect HTTP interim response code to a log file, the httpd daemon used a NULL pointer instead of a pointer to the real request. As a consequence, httpd could terminate unexpectedly with a segmentation fault if the back-end server sent incorrect interim response code. With this update, the correct HTTP request pointer is passed to the httpd logging code, and httpd no longer crashes in this scenario.
Story Points: ---
Clone Of: 1298866
Environment:
Last Closed: 2016-02-09 03:45:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcel Kolaja 2016-01-21 08:59:48 EST
This bug has been copied from bug #1298866 and has been proposed
to be backported to 6.7 z-stream (EUS).
Comment 8 errata-xmlrpc 2016-02-09 03:45:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0136.html

Note You need to log in before you can comment on or make changes to this bug.