Bug 1300739 - Kdocker fails to grab mouse
Kdocker fails to grab mouse
Status: CLOSED DUPLICATE of bug 1314500
Product: Fedora
Classification: Fedora
Component: kdocker (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Raphael Groner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-21 10:21 EST by Ervin
Modified: 2016-03-03 14:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-03 13:24:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ervin 2016-01-21 10:21:08 EST
Description of problem:
Kdocker does not launch because it fails to grab mouse

Version-Release number of selected component (if applicable):
5.0-3.fc23


How reproducible:
Always


Steps to Reproduce:
1.Install Kdocker from gnome-software
2.Launch Kdocker


Actual results:
Kdocker displays an error dialog: Kdocker failed to grab mouse


Expected results:
Kdocker should be able to grab mouse and a Kdocker dependence needed for this, (if that is the case) should be installed together with Kdocker. 


Additional info:
Is it perhaps related to the klauncher bug in Dolphin and perhaps requires the kdeinit5 to be installed?
Comment 1 Rex Dieter 2016-01-21 10:26:13 EST
Are you possibly running a gnome3/wayland session?

If so, I'm guessing that kdocker may not work properly in such an environment.
Comment 2 Raphael Groner 2016-01-21 11:13:02 EST
I run kdocker in Cinnamon (Gtk3 based as GNOME3 is) and can not reproduce your issue. Not sure if that's related somehow to wayland.
Comment 3 Ervin 2016-01-24 13:55:03 EST
I am running kdocker in gnome 3 not wayland.
Comment 4 Ervin 2016-01-24 14:03:02 EST
It is funny, when I launch kdocker now from gnome-software, it works and it can capture gnome-software first, but when I click on the kdocker icon on the desktop I get the same error.
Comment 5 Raphael Groner 2016-03-03 13:24:33 EST
No chance for me to reproduce. Please provide more information about your system. Feel free to reopen this bug if you still see any issue.
Comment 6 Raphael Groner 2016-03-03 14:19:22 EST

*** This bug has been marked as a duplicate of bug 1314500 ***

Note You need to log in before you can comment on or make changes to this bug.