Bug 130075 - Kugar saves *.kut files in binary format and effects sum reporting
Kugar saves *.kut files in binary format and effects sum reporting
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: koffice (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-16 17:06 EDT by Don Dixon
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-20 10:18:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Dixon 2004-08-16 17:06:17 EDT
Description of problem:

When using Kugar Designer (kudesigner) and saving a template file
(*.kut) the file is saved in some sort of binary format as opposed to
plain text.  Noticed problem when I was trying to produce a "sum"
field while working through the on-line how-to.


Version-Release number of selected component (if applicable):
Kugar (as far as I know) is part of koffice.  Version of koffice
installed is koffice-1.3-6.

How reproducible:

Every instance tried reproduces the binary *.kut file.

Steps to Reproduce:
1.  Run sample *.kud (sample1.kud) file against sample *.kut
(sample1.kut) file and see Kugar report with sum visible.
2.  Cat sample *.kut file (sample1.kut) and check to see if it is
plain text readable.
3.  Open sample *.kut file (sample1.kut) in Kugar Designer (kudesigner).
4.  Make no modification to the file and save it (or export it).
5.  Cat sample1.kut and see lots of binary unreadable characters.
5.  Run sample *.kud file (sample1.kud) against now binary formatted
template (sample1.kut) and see report without sum attached.
  
Actual results:
*.kut files are being saved in some sort of binary format.  Kugar can
read the template but is unable to produce sums.


Expected results:
*.kut files should be saved in readable plain text format.  Kugar can
read the template and produce sums on the report.

Additional info:
Comment 1 Don Dixon 2004-08-20 10:18:59 EDT
I submitted this to bugzilla at KDE as well and have received input as
to the binary file type.  Turns out that Kugar Designer 1.3 or better
zip archives the kut files now.  

I still am having problems concerning calculated fields.  

See http://bugs.kde.org/show_bug.cgi?id=87445 for more info.  

If KDE determines the bug to be on their side, I will request this bug
report to be closed here.

Don
Comment 2 Don Dixon 2004-08-20 10:21:04 EDT
Hmmm, I see that this has already been closed.  I guess I will reopen
if KDE people say the bug is with Fedora.

Curious, I never received an email as to the status change.

Don

Note You need to log in before you can comment on or make changes to this bug.