Bug 1300774 - Need updated qpid debug logging in foreman-debug
Need updated qpid debug logging in foreman-debug
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp (Show other bugs)
6.1.6
Unspecified Unspecified
unspecified Severity high (vote)
: 6.1.6
: --
Assigned To: Mike McCune
Sachin Ghai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-21 11:57 EST by Mike McCune
Modified: 2017-02-23 14:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Additional logging information has been added to foreman-debug to improve response time for debugging Qpid errors.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-28 02:25:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
foreman-debug containing qpid logs and location to new script "qpic-core-dump" (52.05 KB, image/png)
2016-01-27 01:29 EST, Sachin Ghai
no flags Details

  None (edit)
Description Mike McCune 2016-01-21 11:57:36 EST
Due to the complex nature of debugging qpid related issues we need some updated logs and information gathered during a run of foreman-debug.

A patch for this can be found here:

https://gitlab.sat.lab.tlv.redhat.com/satellite6/katello/merge_requests/116
Comment 1 Mike McCune 2016-01-21 11:58:28 EST
This is an offshoot of this very high-priority bz:

https://bugzilla.redhat.com/show_bug.cgi?id=1288223
Comment 5 Sachin Ghai 2016-01-27 01:28:33 EST
Verified with 6.1.6  "Compose 7"

I can see qpid-core-dump script and can see foreman-debug updated with additional qpid related information along with following:

- pulp-running_tasks
- mongo-reserved_resource
- mongo-task_status   
- mongo-reserved_resources
- qpid-rpm-qa
- qpid-stat-c
- qpid-stat-q
- qpid-stat-resource_manager
- qpid-stat-u

[root@ibm-x3250m4-07 foreman-debug-QpXzE]# type qpid-core-dump 
qpid-core-dump is /usr/bin/qpid-core-dump


Please see the attached screenshot for verification.
Comment 6 Sachin Ghai 2016-01-27 01:29 EST
Created attachment 1118700 [details]
foreman-debug containing qpid logs and location to new script "qpic-core-dump"
Comment 7 Sachin Ghai 2016-01-27 01:30:29 EST
Moving this bz to verified as per comment 5 and 6
Comment 9 errata-xmlrpc 2016-01-28 02:25:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0076

Note You need to log in before you can comment on or make changes to this bug.