Bug 1300801 - [UX] dnf incorrectly displays installed size for large packages [NEEDINFO]
[UX] dnf incorrectly displays installed size for large packages
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
26
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: Jaroslav Rohel
Fedora Extras Quality Assurance
: EasyFix, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-21 13:27 EST by Jonathan Underwood
Modified: 2017-06-14 10:44 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-14 10:44:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jmracek: needinfo? (jonathan.underwood)


Attachments (Terms of Use)

  None (edit)
Description Jonathan Underwood 2016-01-21 13:27:30 EST
Description of problem:
When installing or removing a package which has a very big installed size, the Installed size is displayed incorrectly as "16E", presumably there's an overflow occuring somewhere, or incorrect formatting statement or somesuch.

Eg.

# dnf install ./Mathematica-10.3.0-1.fc23.x86_64.rpm 
Last metadata expiration check performed 0:22:19 ago on Thu Jan 21 17:58:53 2016.
Dependencies resolved.
========================================================================================================================================================
 Package                             Arch                           Version                                  Repository                            Size
========================================================================================================================================================
Installing:
 Mathematica                         x86_64                         10.3.0-1.fc23                            @commandline                         2.5 G

Transaction Summary
========================================================================================================================================================
Install  1 Package

Total size: 2.5 G
Installed size: 16 E


This is with dnf version 1.1.5-1.fc23
Comment 1 Fedora Admin XMLRPC Client 2016-07-08 05:40:29 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Fedora End Of Life 2016-11-24 10:05:59 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 3 Fedora End Of Life 2017-02-28 04:52:59 EST
This bug appears to have been reported against 'rawhide' during the Fedora 26 development cycle.
Changing version to '26'.
Comment 4 Jaroslav Mracek 2017-04-28 08:03:37 EDT
Please, we tried it but we were unable to reproduce it with dnf-2.3. We are not sure if the problem was solved or the lack of Mathematica rpm could be the point. Please can you reproduce the problem with latest dnf and libsolv version (dnf-0:2.3.0_1-17g1f1b2b6, libsolv-0.6.27-1 or later version) from our test repository (dnf copr enable rpmsoftwaremanagement/dnf-nightly). We provide there rpm for Fedora 24 or later version. Unfortunately without your help we have no other choices than close it as insufficient data.
Comment 5 Jaroslav Rohel 2017-05-04 12:38:45 EDT
I am able to reproduce the problem. I created RPM with 15GB file.

Problem is in bad or unimplemented support for large files somewhere (dnf, libdnf, libsolv). So I am working on it.

During tests I found probably similar problem in  utility for creating repos - createrepo_c lack support for large files in RPM. It stores "0" if the size is too big. Example of bad line in primary.xml file:
 <size package="2294242" installed="0" archive="0"/>

This error causes problems later during using this repo.
DNF then will show: Installed size: 0
I created PR: https://github.com/rpm-software-management/createrepo_c/pull/76

With PR is OK:
<size package="2294242" installed="15728640000" archive="15728640140"/>
Comment 6 Jaroslav Rohel 2017-05-09 09:44:16 EDT
Bug is in the libsolv library.
I made a fix PR https://github.com/openSUSE/libsolv/pull/196
Comment 7 Jaroslav Mracek 2017-06-14 10:44:00 EDT
The patch was merged and will be part of next release of libsolv-0.6.28

Note You need to log in before you can comment on or make changes to this bug.