Bug 1300805 - ppc64 kvm guests do not collect a virt.uuid fact.
ppc64 kvm guests do not collect a virt.uuid fact.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.8
ppc64 Unspecified
medium Severity medium
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
: Triaged
Depends On:
Blocks: rhsm-ppc64
  Show dependency treegraph
 
Reported: 2016-01-21 13:38 EST by Adrian Likins
Modified: 2016-05-10 16:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:39:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrian Likins 2016-01-21 13:38:50 EST
Description of problem:
virt.uuid is only collected from DMI, which isn't available on ppc64.

The info is available in /proc/device-tree/vm,uuid, so it could
be collected from there.


Steps to Reproduce:
1. On a ppc64 kvm guest...
2. subscription-manager facts --list | grep virt.uuid

Actual results:
No virt.uuid

Expected results:
virt.uuid is the same as contents of /proc/device-tree/vm,uuid

This makes VDC and virt bound subscriptions difficult on ppc64 systems.
Comment 2 Adrian Likins 2016-01-21 14:05:15 EST
pr for upstream at https://github.com/candlepin/subscription-manager/pull/1376
Comment 3 Chris Snyder 2016-01-27 13:23:54 EST
The fix has been merged into upstream master as of the below information:

commit f8416137a3b426aa54608116e005df7273abfada
Author: Adrian Likins <alikins@redhat.com>
Date:   Wed Jan 20 16:59:03 2016 -0500

    1300805: Add support for ppc64 virt.uuid
    
    For ppc64 guests running under KVM, the virt.uuid
    is available from '/proc/device-tree/vm,uuid' so
    collect it from there.
    
    Also update scripts/test_hwprobe.sh to DWIM.
Comment 6 Rehana 2016-02-10 10:21:13 EST
Reproducing the failure with old subscription-manager packages 
--------

[root@ibm-p8-kvm-03-guest-03 ~]# cat /proc/device-tree/vm,uuid
4100372a-b35e-4f0e-9b51-3c58a630218f

[root@ibm-p8-kvm-03-guest-03 ~]# 
[root@ibm-p8-kvm-03-guest-03 ~]# subscription-manager facts --list | grep virt.uuid

[root@ibm-p8-kvm-03-guest-03 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.51.11-1
subscription management rules: 5.15
subscription-manager: 1.16.8-1.el6
python-rhsm: 1.16.6-1.el6
[root@ibm-p8-kvm-03-guest-0

After updating the subscription-manager packages
----------------------------------------------
[root@ibm-p8-kvm-03-guest-03 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.51.11-1
subscription management rules: 5.15
subscription-manager: 1.16.8-2.el6
python-rhsm: 1.16.6-1.el6


[root@ibm-p8-kvm-03-guest-03 ~]# cat /proc/device-tree/vm,uuid
4100372a-b35e-4f0e-9b51-3c58a630218f

[root@ibm-p8-kvm-03-guest-03 ~]# subscription-manager facts --list | grep -a "virt.uuid"
virt.uuid: 4100372a-b35e-4f0e-9b51-3c58a630218f

Observed that virt-uuid on the facts list , displayed the same details as in 
/proc/device-tree/vm,uuid

Marking Verified!!!


Additional details about the guest (beaker machine)
--------------------------------------------------
[root@ibm-p8-kvm-03-guest-03 ~]# ls -1 /dev/disk/by-id/
dm-name-vg_ibmp8kvm03guest03-lv_home
dm-name-vg_ibmp8kvm03guest03-lv_root
dm-name-vg_ibmp8kvm03guest03-lv_swap
dm-uuid-LVM-F8pDZ2s0i8cM62cvi8WlvETaUYIkkxiad9T7qsyBmezf4sTMN1JU14Rsc0PSP5C8
dm-uuid-LVM-F8pDZ2s0i8cM62cvi8WlvETaUYIkkxiaNeO1lNvdTI9XMgH1EnYtGq776zfbzUJE
dm-uuid-LVM-F8pDZ2s0i8cM62cvi8WlvETaUYIkkxiaNXaeZNffZlxWvd3QwQckoRcJyTpW3eX5
lvm-pv-uuid-DhDaVO-fvJw-w0V2-d0Rz-twCU-fYt1-4uTvY0
[root@ibm-p8-kvm-03-guest-03 ~]# 

[root@ibm-p8-kvm-03-guest-03 ~]# grep --color qemu /proc/cpuinfo
model		: IBM pSeries (emulated by qemu)
machine		: CHRP IBM pSeries (emulated by qemu)
Comment 8 errata-xmlrpc 2016-05-10 16:39:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0797.html

Note You need to log in before you can comment on or make changes to this bug.