Bug 1300824 - Can get the UI in a weird state by configuring for CDN, and then changing your mind for disconnected
Can get the UI in a weird state by configuring for CDN, and then changing you...
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity medium
: ga
: 1.0
Assigned To: Erik Nelson
Tasos Papaioannou
: Triaged
Depends On:
Blocks: qci-sprint-17
  Show dependency treegraph
 
Reported: 2016-01-21 15:36 EST by Matt Reid
Modified: 2016-09-13 12:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:24:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2016-01-21 15:36:03 EST
Description of problem:
Not sure if this is related to the mocked test environment or not, but if you configure for CDN, advance to the review step, jump back and change to the disconnected radio button (which leaves Review available to click on in the Nav, even if Next is disabled), put in a content mirror URL, and then jump to Review through the Nav, you'll see that the manifest is missing, but the Deploy button is enabled. Additionally, if you click on Back from the Review page, you can see the manifest table with several empty rows, in addition to what the manifest actually contains (although it's using the one I selected through the connected steps, since I didn't upload a manifest through the disconnected steps).

There's a video on the card, that does a better job explaining it :)

Version-Release number of selected component (if applicable):
current demo system
Comment 2 Erik Nelson 2016-02-02 11:55:33 EST
PR667:

https://github.com/fusor/fusor/pull/667

Disabled deploy if configured for disconnected deployment and no manifest file present.

I was unable to repro the corrupt table, think it's likely that was due to the mocked environment.
Comment 4 Tasos Papaioannou 2016-03-24 15:06:15 EDT
The Next button is disabled if I enter a content mirror URL without also uploading a manifest, but if I instead upload a manifest without entering a URL, the Next button is enabled, and I'm able to start the deployment, even though the Installation Review tab shows that the URL is a required field:

Subscriptions
Content Mirror URL required field
Manifest File      /usr/share/foreman/tmp/import_a0511a183d5eb6eda2b3.zip
Quantity           0 - no subscriptions in manifest

Note that the Quantity shows as 0, even though it is a valid manifest that works fine if I select it in connected mode, or when specifying the content URL. If I follow the steps in https://bugzilla.redhat.com/show_bug.cgi?id=1300824#c0 , the deployment goes ahead and syncs content from the Red Hat CDN, and under Content > Red Hat Subscriptions, I see the manifest that I selected from RHN before trying to upload the other manifest manually.
Comment 5 Erik Nelson 2016-06-22 11:40:12 EDT
This PR should ensure next is disabled with a manifest but no content mirror URL: https://github.com/fusor/fusor/pull/741

It was merged in late March and is in current composes.

Additionally, we are validating entitlement counts this sprint to ensure a deployment is covered by a valid subscription quantities.
Comment 7 Tasos Papaioannou 2016-06-22 16:59:26 EDT
Verified on QCI-1.2-RHEL-7-20160621.t.0.
Comment 13 errata-xmlrpc 2016-09-13 12:24:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.