Bug 1300848 - RHN channels to product cert maps for "rhel-x86_64-rhev-mgmt-agent-7*" disappeared
RHN channels to product cert maps for "rhel-x86_64-rhev-mgmt-agent-7*" disapp...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager-migration-data (Show other bugs)
6.8
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
: Regression, Triaged
Depends On:
Blocks: 1319072
  Show dependency treegraph
 
Reported: 2016-01-21 17:15 EST by John Sefler
Modified: 2016-05-10 16:39 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1319072 (view as bug list)
Environment:
Last Closed: 2016-05-10 16:39:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2016-01-21 17:15:25 EST
Description of problem:
The RHN channel to product cert maps in subscription-manager-migration-data disappeared for four rhel-x86_64-rhev-mgmt-agent-7 channels.  I suspect this was an automated mistake introduced by rcm commit...

http://git.app.eng.bos.redhat.com/git/rcm/rcm-metadata.git/commit/?id=30f4db8f9d0a9b5709abd662690ef74a9bf21723


Version-Release number of selected component (if applicable):
subscription-manager-migration-data-2.0.25-1.el6.noarch


How reproducible:


Steps to Reproduce:
On RHEL6.7...
[root@jsefler-6 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-2.0.22-1.el6.noarch
[root@jsefler-6 ~]# grep rhel-x86_64-rhev-mgmt-agent-7 /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-rhev-mgmt-agent-7: RHEV-x86_64-fcf7726b7902-150.pem
rhel-x86_64-rhev-mgmt-agent-7-beta: RHEV-x86_64-fcf7726b7902-150.pem
rhel-x86_64-rhev-mgmt-agent-7-beta-debuginfo: RHEV-x86_64-fcf7726b7902-150.pem
rhel-x86_64-rhev-mgmt-agent-7-debuginfo: RHEV-x86_64-fcf7726b7902-150.pem
[root@jsefler-6 ~]# 

UPGRADE TO RHEL6.8 nightly compose (not shown)

On RHEL6.8...
[root@jsefler-6 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-2.0.25-1.el6.noarch
[root@jsefler-6 ~]# grep rhel-x86_64-rhev-mgmt-agent-7 /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
[root@jsefler-6 ~]# 



Actual results:
above - rhel-x86_64-rhev-mgmt-agent-7* channel maps are absent from subscription-manager-migration-data-2.0.25-1

Expected results:
I can't think of a good reason why these channel maps should have been removed.


Additional info:
Comment 12 John Sefler 2016-03-28 11:35:20 EDT
Verifying Version....

[root@jsefler-6 ~]# rpm -q subscription-manager-migration-data 
subscription-manager-migration-data-2.0.27-1.el6.noarch
[root@jsefler-6 ~]#
[root@jsefler-6 ~]# grep rhel-x86_64-rhev-mgmt-agent-7 /usr/share/rhsm/product/RHEL-6/channel-cert-mapping.txt
rhel-x86_64-rhev-mgmt-agent-7: RHEV-x86_64-fcf7726b7902-150.pem
rhel-x86_64-rhev-mgmt-agent-7-beta: RHEV-x86_64-fcf7726b7902-150.pem
rhel-x86_64-rhev-mgmt-agent-7-beta-debuginfo: RHEV-x86_64-fcf7726b7902-150.pem
rhel-x86_64-rhev-mgmt-agent-7-debuginfo: RHEV-x86_64-fcf7726b7902-150.pem
[root@jsefler-6 ~]#
[root@jsefler-6 ~]# rct cat-cert /usr/share/rhsm/product/RHEL-6/RHEV-x86_64-fcf7726b7902-150.pem

+-------------------------------------------+
	Product Certificate
+-------------------------------------------+

Certificate:
	Path: /usr/share/rhsm/product/RHEL-6/RHEV-x86_64-fcf7726b7902-150.pem
	Version: 1.0
	Serial: 12750047592154746405
	Start Date: 2015-04-14 13:55:46+00:00
	End Date: 2035-04-09 13:55:46+00:00

Subject:
	CN: Red Hat Product ID [cead7bb3-0e18-43df-85eb-fcf7726b7902]

Issuer:
	C: US
	CN: Red Hat Entitlement Product Authority
	O: Red Hat, Inc.
	OU: Red Hat Network
	ST: North Carolina
	emailAddress: ca-support@redhat.com

Product:
	ID: 150
	Name: Red Hat Enterprise Virtualization
	Version: 3.6
	Arch: x86_64
	Tags: 
	Brand Type: 
	Brand Name: 

[root@jsefler-6 ~]# 


VERIFIED: The RHN channels to product cert maps for "rhel-x86_64-rhev-mgmt-agent-7*" have been restored.
Comment 14 errata-xmlrpc 2016-05-10 16:39:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0797.html

Note You need to log in before you can comment on or make changes to this bug.