Bug 1300893 - Organization and location setting of 'all users' prevents user from selecting organization or location
Organization and location setting of 'all users' prevents user from selecting...
Status: CLOSED DUPLICATE of bug 1321543
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Organizations and Locations (Show other bugs)
6.1.6
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Kavita
: Triaged
Depends On: 1321543
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-21 20:40 EST by dzr0001
Modified: 2017-08-11 08:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-11 08:46:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Foreman logs (11.43 KB, text/plain)
2016-01-21 21:08 EST, dzr0001
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 6150 None None None 2017-07-19 06:55 EDT

  None (edit)
Description dzr0001 2016-01-21 20:40:09 EST
Description of problem:

In order to allow autocreated users access to locations and organzations, the 'all users' box was ticked. All created users display properly in the 'selected items' column.

However, so long as this box is ticked, a user cannot select an organization or location, preventing them from viewing organization or location specific objects such as content hosts.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. As admin user select 'all users' for an organization/location
2. As regular user logout/login to Satellite
3. Context switcher for organization/location do not display choices
4. Deselect 'all users' for organization/location
5. As regular user logout/login
6. Context switcher works as expected
7. Reselect 'all users' and observe broken behavior again

Actual results:

User cannot select context when 'all users' is selected for an organization or location.

Expected results:

User should be able to select an organization or location that they are assigned to if they are assigned via 'all users' option.

Additional info:
Comment 1 dzr0001 2016-01-21 21:08 EST
Created attachment 1117079 [details]
Foreman logs

This log shows the state of the organization database entry when 'all users' is checked vs unchecked. Also, I've added a grep of 'Organization' from the foreman production log when the option was checked, unchecked, and re-checked.
Comment 3 Bryan Kearney 2016-07-08 16:23:53 EDT
Per 6.3 planning, moving out non acked bugs to the backlog
Comment 6 pm-sat@redhat.com 2017-07-19 08:15:25 EDT
Upstream bug assigned to kgaikwad@redhat.com
Comment 7 pm-sat@redhat.com 2017-07-19 08:15:28 EDT
Upstream bug assigned to kgaikwad@redhat.com
Comment 8 Bryan Kearney 2017-08-11 08:46:25 EDT
Marking this as a dupe of  https://bugzilla.redhat.com/show_bug.cgi?id=1321543
 based on engineering research.

*** This bug has been marked as a duplicate of bug 1321543 ***

Note You need to log in before you can comment on or make changes to this bug.