Bug 1300924 - Fix mem leaks related to gfapi applications
Fix mem leaks related to gfapi applications
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: libgfapi (Show other bugs)
3.7.7
All All
unspecified Severity medium
: ---
: ---
Assigned To: bugs@gluster.org
Sudhir D
: Triaged
Depends On: 1295107 1311441
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-22 01:03 EST by Soumya Koduri
Modified: 2016-04-19 03:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1295107
Environment:
Last Closed: 2016-04-19 03:52:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Soumya Koduri 2016-01-22 01:03:06 EST
+++ This bug was initially created as a clone of Bug #1295107 +++

Description of problem:

This bug is to track the changes required to fix mem leaks related to gfapi applications.

--- Additional comment from Vijay Bellur on 2016-01-04 09:22:51 EST ---

REVIEW: http://review.gluster.org/13125 (inode: Retire the inodes from the lru list in inode_table_destroy) posted (#2) for review on master by soumya k (skoduri@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-05 00:51:37 EST ---

REVIEW: http://review.gluster.org/13096 (gfapi: Fix inode reference/nlookup counts) posted (#3) for review on master by soumya k (skoduri@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-11 05:23:23 EST ---

REVIEW: http://review.gluster.org/13096 (gfapi: Fix inode nlookup counts) posted (#4) for review on master by soumya k (skoduri@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-13 01:13:14 EST ---

REVIEW: http://review.gluster.org/13232 (upcall: free the xdr* allocations) posted (#1) for review on master by soumya k (skoduri@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-14 06:39:27 EST ---

COMMIT: http://review.gluster.org/13232 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 7d6e5dad15b7ecf2e8abce468aea9fd84b876052
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Wed Jan 13 11:34:27 2016 +0530

    upcall: free the xdr* allocations
    
    Free the xdr string allocations after decoding the upcall
    cache_invalidation request.
    
    Change-Id: I0ffc64f587d6c8566cba76cf08148f937a735926
    BUG: 1295107
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/13232
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Comment 1 Vijay Bellur 2016-01-22 01:04:12 EST
REVIEW: http://review.gluster.org/13277 (upcall: free the xdr* allocations) posted (#1) for review on release-3.7 by soumya k (skoduri@redhat.com)
Comment 2 Vijay Bellur 2016-01-24 12:13:21 EST
COMMIT: http://review.gluster.org/13277 committed in release-3.7 by Niels de Vos (ndevos@redhat.com) 
------
commit b313b72ab0bf1fbc92b8b201ea4154ce5fd73c88
Author: Soumya Koduri <skoduri@redhat.com>
Date:   Wed Jan 13 11:34:27 2016 +0530

    upcall: free the xdr* allocations
    
    Free the xdr string allocations after decoding the upcall
    cache_invalidation request.
    
    This is backport of the below fix
       - http://review.gluster.org/13232
    
    Change-Id: I0ffc64f587d6c8566cba76cf08148f937a735926
    BUG: 1300924
    Signed-off-by: Soumya Koduri <skoduri@redhat.com>
    Reviewed-on: http://review.gluster.org/13232
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/13277
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Kaushal 2016-04-19 03:52:59 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.