This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1300978 - I/O failure during a graph change followed by an option change.
I/O failure during a graph change followed by an option change.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: protocol (Show other bugs)
3.7.7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mohammed Rafi KC
:
Depends On: 1300564
Blocks: 1300301
  Show dependency treegraph
 
Reported: 2016-01-22 04:20 EST by Mohammed Rafi KC
Modified: 2016-04-19 03:52 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1300564
Environment:
Last Closed: 2016-04-19 03:52:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Rafi KC 2016-01-22 04:20:21 EST
+++ This bug was initially created as a clone of Bug #1300564 +++

Description of problem:

I/O failed for fuse mount when a graph changed followed by an option changed

Version-Release number of selected component (if applicable):

mainline

How reproducible:

very inconsistent. It is a race

Steps to Reproduce:

1. Start i/o on fuse mount
2. Disable write-behind (just to have a graph change)
3. immediately enable trash (just to have an option change in server side)
4. I/o will fail with transport end point not connected

Actual results:

I/O failure

Expected results:

I/O should not fail

Additional info:

--- Additional comment from Vijay Bellur on 2016-01-21 02:27:12 EST ---

REVIEW: http://review.gluster.org/13271 (protocol/server: Race between server_reconfigure and server_setvolume) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-21 02:38:55 EST ---

REVIEW: http://review.gluster.org/13271 (protocol/server: Race between server_reconfigure and server_setvolume) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-21 03:27:03 EST ---

REVIEW: http://review.gluster.org/13271 (protocol/server: Race between server_reconfigure and server_setvolume) posted (#3) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Vijay Bellur on 2016-01-22 03:52:23 EST ---

COMMIT: http://review.gluster.org/13271 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 16f6579cb3e1214b1386fb530b8e16c8cbfdef33
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Thu Jan 21 12:41:55 2016 +0530

    protocol/server: Race between server_reconfigure and server_setvolume
    
    During server_reconfigure we authenticate each connected clients
    against the current options. To do this authentication we store
    previous values in a dictionary during the connection establishment
    phase (server_setvolume). If the authentication fails during
    reconfigure then we will disconnect the transport.
    
    Here it introduce a race between server_setvolume and reconfugure.
    If a reconfigure called before doing a setvolume, the transport
    will be disconnected
    
    Change-Id: Icce2c28a171481327a06efd3901f8a5ee67b05ab
    BUG: 1300564
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/13271
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 1 Vijay Bellur 2016-01-22 04:24:01 EST
REVIEW: http://review.gluster.org/13280 (protocol/server: Race between server_reconfigure and server_setvolume) posted (#1) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Vijay Bellur 2016-01-26 01:28:20 EST
COMMIT: http://review.gluster.org/13280 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 30e4d0db013ece366c5036b1d82c0150f082128a
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Thu Jan 21 12:41:55 2016 +0530

    protocol/server: Race between server_reconfigure and server_setvolume
    
    During server_reconfigure we authenticate each connected clients
    against the current options. To do this authentication we store
    previous values in a dictionary during the connection establishment
    phase (server_setvolume). If the authentication fails during
    reconfigure then we will disconnect the transport.
    
    Here it introduce a race between server_setvolume and reconfugure.
    If a reconfigure called before doing a setvolume, the transport
    will be disconnected
    
    Backport of>
    >Change-Id: Icce2c28a171481327a06efd3901f8a5ee67b05ab
    >BUG: 1300564
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: http://review.gluster.org/13271
    >Smoke: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    >CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    
    (cherry picked from commit 16f6579cb3e1214b1386fb530b8e16c8cbfdef33)
    
    Change-Id: I8ab7ad4bd5d2d70bcdae7bcbc233930bcfbeb411
    BUG: 1300978
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/13280
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 3 Kaushal 2016-04-19 03:52:59 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.