Bug 1300986 - Cluster link leads to a login page
Summary: Cluster link leads to a login page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 2
Assignee: kamlesh
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-22 09:42 UTC by Martin Bukatovic
Modified: 2016-08-23 19:46 UTC (History)
4 users (show)

Fixed In Version: rhscon-ui-0.0.11-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:46:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
"Clusters" page screenshot (34.42 KB, image/png)
2016-01-22 09:42 UTC, Martin Bukatovic
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1296185 None None None Never
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Internal Links: 1296185

Description Martin Bukatovic 2016-01-22 09:42:24 UTC
Created attachment 1117137 [details]
"Clusters" page screenshot

Description of problem
======================

Cluster entry on "Clusters" page contains incorrect html link which leads to a
login page.

Version-Release number of selected component
============================================

# rpm -qa 'rhscon*'
rhscon-core-0.0.6-0.1.alpha1.el7.x86_64
rhscon-ui-0.0.6-0.1.alpha1.el7.noarch
rhscon-ceph-0.0.4-0.1.alpha1.el7.x86_64

How reproducible
================

100 % (assuming you manage to create the cluster with success)

Steps to Reproduce
==================

1. Install skyring on server and prepare few hosts for cluster setup
2. Accept all nodes
3. Create new cluster using "Create Cluster" wizard
4. Go to "Clusters" page and see the entry of new cluster there

Actual results
==============

The name of the cluster is a html link which leads to the following url:

http://usm-server.example.com:8080/#/clusters/detail/

When clicked, a login page is shown.

See attached screenshot, the link discussed here (and the name of cluster) is
named "cluster01".

Expected results
================

The name of the cluster is a html link which leads to a page with details of
this particular cluster.

Comment 1 Kanagaraj 2016-02-03 09:01:34 UTC
Clicking on the cluster name now will take the user to cluster dashboard

Comment 3 Martin Kudlej 2016-07-01 12:30:07 UTC
Tested with rhscon-ui-0.0.43-1.el7scon.noarch and it works. -> VERIFIED

Comment 6 errata-xmlrpc 2016-08-23 19:46:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.