Bug 1301006 - Samba does not start anymore on server
Samba does not start anymore on server
Status: CLOSED DUPLICATE of bug 1300038
Product: Fedora
Classification: Fedora
Component: samba4 (Show other bugs)
23
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-22 05:13 EST by Fujisan
Modified: 2016-01-22 05:28 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-22 05:28:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fujisan 2016-01-22 05:13:52 EST
Description of problem:
I just upgraded my system (dnf update) and it installed the lastest version of samba (4.3.4)

$ rpm -qa|grep samba |sort
samba-4.3.4-0.fc23.x86_64
samba-client-4.3.4-0.fc23.x86_64
samba-client-libs-4.3.4-0.fc23.x86_64
samba-common-4.3.4-0.fc23.noarch
samba-common-libs-4.3.4-0.fc23.x86_64
samba-common-tools-4.3.4-0.fc23.x86_64
samba-libs-4.3.4-0.fc23.x86_64
samba-python-4.3.4-0.fc23.x86_64
samba-test-4.3.4-0.fc23.x86_64
samba-test-libs-4.3.4-0.fc23.x86_64
samba-winbind-4.3.4-0.fc23.x86_64
samba-winbind-clients-4.3.4-0.fc23.x86_64
samba-winbind-krb5-locator-4.3.4-0.fc23.x86_64
samba-winbind-modules-4.3.4-0.fc23.x86_64

But now I cannot start samba server.

# smbd -F -d 1 -S
smbd version 4.3.4 started.
Copyright Andrew Tridgell and the Samba Team 1992-2015
lp_load_ex: changing to config backend registry
Bad talloc magic value - wrong talloc version used/mixed
PANIC: Bad talloc magic value - wrong talloc version used/mixed
Aborted (core dumped)

# systemctl restart smb.service 
Job for smb.service failed because a fatal signal was delivered causing the control process to dump core. See "systemctl status smb.service" and "journalctl -xe" for details.

# systemctl status smb.service 
● smb.service - Samba SMB Daemon
   Loaded: loaded (/usr/lib/systemd/system/smb.service; disabled; vendor preset: disabled)
   Active: failed (Result: core-dump) since Fri 2016-01-22 10:53:50 CET; 8min ago
  Process: 130127 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=dumped, signal=ABRT)
 Main PID: 130127 (code=dumped, signal=ABRT)

Jan 22 10:53:50 zaira2.opera systemd[1]: Starting Samba SMB Daemon...
Jan 22 10:53:50 zaira2.opera systemd[1]: smb.service: Main process exited, code=dumped, status=6/ABRT
Jan 22 10:53:50 zaira2.opera systemd[1]: Failed to start Samba SMB Daemon.
Jan 22 10:53:50 zaira2.opera systemd[1]: smb.service: Unit entered failed state.
Jan 22 10:53:50 zaira2.opera systemd[1]: smb.service: Failed with result 'core-dump'.

And there is no log in /var/log/samba.

Version-Release number of selected component (if applicable):
4.3.4

How reproducible:
always

Steps to Reproduce:
1. Upgrade to samba 4.3.4
2. try systemctl restart smb.service
3.

Actual results:
Unable to access linux shares from windows.

Expected results:
Access to linux shares from windows.
Comment 1 Guenther Deschner 2016-01-22 05:28:14 EST

*** This bug has been marked as a duplicate of bug 1300038 ***

Note You need to log in before you can comment on or make changes to this bug.