Bug 1301015 - IPv4 VIP resources get created with 64 cidr_netmask in mixed IPv4/IPv6 environment
Summary: IPv4 VIP resources get created with 64 cidr_netmask in mixed IPv4/IPv6 enviro...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: y3
: 7.0 (Kilo)
Assignee: Giulio Fidente
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On: 1301046
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-22 10:44 UTC by Marius Cornea
Modified: 2016-02-18 16:51 UTC (History)
5 users (show)

Fixed In Version: openstack-tripleo-heat-templates-0.8.6-112.el7ost
Doc Type: Bug Fix
Doc Text:
In mixed environments where some networks use IPv4 addressing and others IPv6 addressing, the Overcloud used IPv6 CIDR for IPv4 VIPs too. The Overcloud deployment failed because Pacemaker refused to start the IPv4 VIPs. This fix adds functionality to identify the VIP type (IPv4 or IPv6) during deployment and adapt the appropriate CIDR. Each IPv4 and IPv6 VIP now uses the appropriate CIDR.
Clone Of:
: 1301046 (view as bug list)
Environment:
Last Closed: 2016-02-18 16:51:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 267647 None MERGED Set /64 cidr_netmask for pcmk VIPs when IPv6 2020-01-30 16:14:34 UTC
Red Hat Product Errata RHBA-2016:0264 normal SHIPPED_LIVE Red Hat Enterprise Linux OSP 7 director Bug Fix Advisory 2016-02-18 21:41:29 UTC

Description Marius Cornea 2016-01-22 10:44:29 UTC
Description of problem:
IPv4 public VIP resources get created with 64 cidr_netmask in mixed IPv4/IPv6 environment

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-0.8.6-110.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy mixed IPv4/IPv6 environment (storage and storage management network on ipv4)

Actual results:
The IPV4 VIP resource are unable to start:
root@overcloud-controller-0 ~]# pcs status | grep Stopped
 ip-172.16.3.4	(ocf::heartbeat:IPaddr2):	Stopped
 ip-172.16.1.4	(ocf::heartbeat:IPaddr2):	Stopped


Expected results:
The resources get started.

Additional info:
overcloud-controller-0-ip-172.16.3.4_start_0:6 [ ocf-exit-reason:Invalid netmask specification [64].\n ]

[root@overcloud-controller-0 ~]# pcs resource show  ip-172.16.3.4
 Resource: ip-172.16.3.4 (class=ocf provider=heartbeat type=IPaddr2)
  Attributes: ip=172.16.3.4 cidr_netmask=64 
  Operations: start interval=0s timeout=20s (ip-172.16.3.4-start-interval-0s)
              stop interval=0s timeout=20s (ip-172.16.3.4-stop-interval-0s)
              monitor interval=10s timeout=20s (ip-172.16.3.4-monitor-interval-10s)

Comment 2 Marius Cornea 2016-01-25 11:40:13 UTC
[root@overcloud-controller-0 ~]# pcs resource show ip-2001.db8.fd00.1000..10
 Resource: ip-2001.db8.fd00.1000..10 (class=ocf provider=heartbeat type=IPaddr2)
  Attributes: ip=2001:db8:fd00:1000::10 cidr_netmask=64 
  Operations: start interval=0s timeout=20s (ip-2001.db8.fd00.1000..10-start-interval-0s)
              stop interval=0s timeout=20s (ip-2001.db8.fd00.1000..10-stop-interval-0s)
              monitor interval=10s timeout=20s (ip-2001.db8.fd00.1000..10-monitor-interval-10s)
[root@overcloud-controller-0 ~]# pcs resource show ip-172.16.3.4
 Resource: ip-172.16.3.4 (class=ocf provider=heartbeat type=IPaddr2)
  Attributes: ip=172.16.3.4 cidr_netmask=32 
  Operations: start interval=0s timeout=20s (ip-172.16.3.4-start-interval-0s)
              stop interval=0s timeout=20s (ip-172.16.3.4-stop-interval-0s)
              monitor interval=10s timeout=20s (ip-172.16.3.4-monitor-interval-10s)
[root@overcloud-controller-0 ~]#

Comment 4 errata-xmlrpc 2016-02-18 16:51:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0264.html


Note You need to log in before you can comment on or make changes to this bug.