Bug 1301032 - [georep+tiering]: Hardlink sync is broken if master volume is tiered
[georep+tiering]: Hardlink sync is broken if master volume is tiered
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
mainline
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Saravanakumar
: ZStream
Depends On: 1300682
Blocks: 1302979
  Show dependency treegraph
 
Reported: 2016-01-22 06:37 EST by Saravanakumar
Modified: 2016-06-16 09:55 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1300682
: 1302979 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:55:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-01-22 06:38:14 EST
REVIEW: http://review.gluster.org/13281 (geo-rep: Handle hardlink in Tiering based volume) posted (#2) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)
Comment 2 Vijay Bellur 2016-01-25 01:05:16 EST
REVIEW: http://review.gluster.org/13281 (geo-rep: Handle hardlink in Tiering based volume) posted (#3) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)
Comment 3 Vijay Bellur 2016-01-27 07:40:26 EST
REVIEW: http://review.gluster.org/13281 (geo-rep: Handle hardlink in Tiering based volume) posted (#4) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)
Comment 4 Vijay Bellur 2016-01-28 03:45:40 EST
REVIEW: http://review.gluster.org/13281 (geo-rep: Handle hardlink in Tiering based volume) posted (#5) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)
Comment 5 Vijay Bellur 2016-01-28 04:37:39 EST
REVIEW: http://review.gluster.org/13281 (geo-rep: Handle hardlink in Tiering based volume) posted (#6) for review on master by Aravinda VK (avishwan@redhat.com)
Comment 6 Vijay Bellur 2016-01-28 08:22:48 EST
REVIEW: http://review.gluster.org/13281 (geo-rep: Handle hardlink in Tiering based volume) posted (#7) for review on master by Venky Shankar (vshankar@redhat.com)
Comment 7 Vijay Bellur 2016-01-29 00:42:29 EST
REVIEW: http://review.gluster.org/13281 (geo-rep: Handle hardlink in Tiering based volume) posted (#8) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)
Comment 8 Vijay Bellur 2016-02-08 03:22:55 EST
REVIEW: http://review.gluster.org/13281 (geo-rep: Handle hardlink in Tiering based volume) posted (#9) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)
Comment 9 Vijay Bellur 2016-02-09 08:59:21 EST
REVIEW: http://review.gluster.org/13281 (geo-rep: Handle hardlink in Tiering based volume) posted (#10) for review on master by Saravanakumar Arumugam (sarumuga@redhat.com)
Comment 10 Vijay Bellur 2016-02-26 04:44:27 EST
COMMIT: http://review.gluster.org/13281 committed in master by Venky Shankar (vshankar@redhat.com) 
------
commit 3f9632cd655f43fa66cca981b37cbfb09ab1d352
Author: Saravanakumar Arumugam <sarumuga@redhat.com>
Date:   Fri Jan 22 16:58:13 2016 +0530

    geo-rep: Handle hardlink in Tiering based volume
    
    Problem:
    Hardlinks are synced as Sticky bit files to Slave in
    a Tiering based volume.
    In a Tiering based volume, cold tier is hashed subvolume
    and geo-rep captures all namespace operations in cold tier.
    
    While syncing a file and its corresponding hardlink, it is
    recorded as MKNOD in cold tier(for both) and
    We end up creating two different files in Slave.
    
    Solution:
    If MKNOD with Sticky bit set is present, record it as LINK.
    This way it will create a HARDLINK if source file exists (on slave),
    else it will create a new file.
    
    This way, Slave can create Hardlink file itself (instead
    of creating a new file) in case of hardlink.
    
    Change-Id: Ic50dc6e64df9ed01799c30539a33daace0abe6d4
    BUG: 1301032
    Signed-off-by: Saravanakumar Arumugam <sarumuga@redhat.com>
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/13281
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 11 Niels de Vos 2016-06-16 09:55:37 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.