Bug 1301037 - Carmart quickstart in CS mode still requires cache-api dependency
Carmart quickstart in CS mode still requires cache-api dependency
Status: CLOSED DUPLICATE of bug 1292720
Product: JBoss Data Grid 6
Classification: JBoss
Component: unspecified (Show other bugs)
6.6.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tristan Tarrant
Martin Gencur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-22 07:05 EST by Jakub Markos
Modified: 2016-01-22 07:33 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-22 07:33:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Markos 2016-01-22 07:05:47 EST
The carmart quickstart in client-server mode fails with CR2 when deploying the application:

mvn jboss-as:deploy -Premote-jbossas

with this error:

Caused by: java.lang.ClassNotFoundException: javax.cache.annotation.CacheResult from [Module \"deployment.jboss-carmart.war:main\" from Service Module Loader]

After adding the cache-api jar to the application, everything works fine.
Comment 2 Martin Gencur 2016-01-22 07:33:01 EST

*** This bug has been marked as a duplicate of bug 1292720 ***

Note You need to log in before you can comment on or make changes to this bug.