Bug 1301056 - In IPv6 deployments the ceilometer compute agent cannot reach the public endpoint
Summary: In IPv6 deployments the ceilometer compute agent cannot reach the public endp...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: y3
: 7.0 (Kilo)
Assignee: Giulio Fidente
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On: 1301126
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-22 13:13 UTC by Marius Cornea
Modified: 2016-02-18 16:51 UTC (History)
4 users (show)

Fixed In Version: openstack-tripleo-heat-templates-0.8.6-112.el7ost
Doc Type: Bug Fix
Doc Text:
The Ceilometer Compute Agent in IPv6-based Overclouds could not reach the public endpoint and reported errors such as: ConnectionError: ('Connection aborted.', gaierror(-2, 'Name or service not known')) This fix switches the endpoint to 'internalURL' instead of 'publicURL'.
Clone Of:
: 1301126 (view as bug list)
Environment:
Last Closed: 2016-02-18 16:51:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 240538 None None None 2016-01-22 13:31:28 UTC
Red Hat Product Errata RHBA-2016:0264 normal SHIPPED_LIVE Red Hat Enterprise Linux OSP 7 director Bug Fix Advisory 2016-02-18 21:41:29 UTC

Description Marius Cornea 2016-01-22 13:13:19 UTC
Description of problem:
In IPv6 deployments the ceilometer compute agent cannot reach the public endpoint so it fails with errors like:
 ConnectionError: ('Connection aborted.', gaierror(-2, 'Name or service not known'))

Since the compute nodes can only reach the isolated network and don't have a means to reach the public endpoint we should switch the os_endpoint_type in /etc/ceilometer/ceilometer.conf to internalURL which can be reachable via the internal_api network.

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-0.8.6-111.el7ost.noarch

How reproducible:
100% 

Steps to Reproduce:
1. Deploy ipv6 enable overcloud
2. Check /var/log/ceilometer/compute.log

Actual results:
ConnectionError: ('Connection aborted.', gaierror(-2, 'Name or service not known'))

Expected results:
There are no errors reported.

Comment 3 errata-xmlrpc 2016-02-18 16:51:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0264.html


Note You need to log in before you can comment on or make changes to this bug.