Bug 1301064 - remote-viewer is missing icons
remote-viewer is missing icons
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.6.2
Unspecified Unspecified
unspecified Severity low
: ovirt-4.0.0-rc
: 4.0.0
Assigned To: Default Assignee for SPICE Bugs
SPICE QE bug list
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-22 08:40 EST by Victor Toso
Modified: 2016-08-23 16:48 EDT (History)
10 users (show)

See Also:
Fixed In Version: mingw-spice-gtk-0.31-2.el7ev mingw-virt-viewer-2.0-10.el7ev rhevm-spice-client-4.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 16:48:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Spice
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example of missing icon (766.34 KB, image/png)
2016-01-22 08:40 EST, Victor Toso
no flags Details

  None (edit)
Description Victor Toso 2016-01-22 08:40:31 EST
Created attachment 1117195 [details]
example of missing icon

Description of problem:
Some icons in remote-viewer are missing

Version-Release number of selected component (if applicable):
virt-viewer-2.0-8 x64

How reproducible:
always

Steps to Reproduce:
1. open remote-viewer
2. under file > usb device selection, select a webcam
3. the image attached as one example

Actual results:
No image, log outputs:

(remote-viewer.exe:8872): Gtk-WARNING **: Error loading theme icon 'dialog-warning' for stock: Icon 'dialog-warning' not present in theme

(remote-viewer.exe:8872): Gtk-WARNING **: Error loading theme icon 'dialog-information' for stock: Icon 'dialog-information' not present in theme

Expected results:
Image and no warnings related to icons

Additional info:
Comment 1 Fabiano Fidêncio 2016-01-25 18:57:57 EST
Toso,

The widget used for USB Redirection is provided by spice-gtk, so the problem is most likely there (kinda) and would be easily fixed by add those missing icons as part of the wxi file for spice-gtk in msitools.

Would you mind checking if this is the only missing icon?

I probably have missed this because for the upstream windows client we don't enable usb redirection.
Comment 2 Victor Toso 2016-01-26 04:35:38 EST
Hi Fabiano,

I don't think the missing icons are related to the usb redirection. They seem to be the default 'dialog-warning' and 'dialog-information' and could be missing in other widgets of virt-viewer.

But so far, those two were the only ones that I see that are missing.
I'm still doing some tests related to Bug 1301088 - If I find other icons, I'll add here.
Comment 3 Fabiano Fidêncio 2016-01-26 04:59:43 EST
(In reply to Victor Toso from comment #2)
> Hi Fabiano,
> 
> I don't think the missing icons are related to the usb redirection. They
> seem to be the default 'dialog-warning' and 'dialog-information' and could
> be missing in other widgets of virt-viewer.

They are related to the library who provides the widget.
For instance, usb-device-widget.c is full of STOCK icons. AFAIU, the .wxi file from this library should provide info about all the icons being used. For virt-viewer, for instance, all the icons being used (including the STOCK ones) are provided by "adwaita-icons-needed.wxi".
Another option would be including the whole adwaita theme as gtk dependency, but then any program using GTK will have its size considerably increased because of the icons, which is better to avoid.

A simple test to do (don't bother doing it, I mentioning just for the record) is adding the image relative to the action to the virt-viewer installed folder. Most likely the problem will disappear and then we can know what exactly has been missing.

I'll take a look on this after we drop GTK2 from spice-gtk, then we can also remove these deprecated stock icons usage ...

> 
> But so far, those two were the only ones that I see that are missing.
> I'm still doing some tests related to Bug 1301088 - If I find other icons,
> I'll add here.

Super, thanks for doing this.
Comment 4 Fabiano Fidêncio 2016-04-26 04:24:07 EDT
I guess the best solution here is to depend on mingw-adaita-icon-theme.
I already opened a bug for branching the package for RHEVM-4.0: https://projects.engineering.redhat.com/browse/RCM-2173
Comment 5 Fabiano Fidêncio 2016-04-26 10:45:57 EDT
Patch sent upstream:
https://www.redhat.com/archives/virt-tools-list/2016-April/msg00097.html
Comment 6 Yaniv Lavi 2016-05-09 06:59:55 EDT
oVirt 4.0 Alpha has been released, moving to oVirt 4.0 Beta target.
Comment 13 errata-xmlrpc 2016-08-23 16:48:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1681.html

Note You need to log in before you can comment on or make changes to this bug.