Bug 1301101 - Add 'NotifyAccess=all' to systemd unit
Add 'NotifyAccess=all' to systemd unit
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rabbitmq-server (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-22 10:23 EST by Alexey Lebedeff
Modified: 2016-01-22 10:40 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-22 10:40:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexey Lebedeff 2016-01-22 10:23:38 EST
Description of problem:

Change was recently merged into rabbitmq upstream (https://github.com/rabbitmq/rabbitmq-server/pull/574) that removes dependency on 'sd_notify' library. 

While this change will only land in RabbitMQ version 3.7.0, I suggest to add
'NotifyAccess=all', because otherwise service with 'Type=notify' will stop working.

Adding it as a bug so no time will be wasted on debugging this issue during packaging of 3.7.0 )
Comment 1 Peter Lemenkov 2016-01-22 10:40:22 EST
(In reply to Alexey Lebedeff from comment #0)
> Description of problem:
> 
> Change was recently merged into rabbitmq upstream
> (https://github.com/rabbitmq/rabbitmq-server/pull/574) that removes
> dependency on 'sd_notify' library. 
> 
> While this change will only land in RabbitMQ version 3.7.0, I suggest to add
> 'NotifyAccess=all', because otherwise service with 'Type=notify' will stop
> working.

We already added NotifyAccess=all to our service-file couple of months ago. See this commit:

http://pkgs.fedoraproject.org/cgit/rpms/rabbitmq-server.git/commit/?id=ad7c119

Anyway, thanks for the tip.

Note You need to log in before you can comment on or make changes to this bug.