Bug 1301106 - Package Review: python-ImcSdk
Package Review: python-ImcSdk
Status: CLOSED NOTABUG
Product: RDO
Classification: Community
Component: Package Review (Show other bugs)
Liberty
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Kilo
Assigned To: hguemar
hguemar
:
Depends On:
Blocks: 1301112
  Show dependency treegraph
 
Reported: 2016-01-22 10:35 EST by Brian Demers
Modified: 2016-02-02 20:34 EST (History)
3 users (show)

See Also:
Fixed In Version: python-ImcSdk-0.7.2-3.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-24 11:00:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
karlthered: rdo‑review+


Attachments (Terms of Use)

  None (edit)
Description Brian Demers 2016-01-22 10:35:56 EST
This is a dependency of python-ironic-cisco

Fedora upstream spec: https://admin.fedoraproject.org/pkgdb/package/rpms/python-ImcSdk/
Source: repo: https://github.com/CiscoUcs/ImcSdk
Comment 2 Alan Pevec 2016-01-22 12:30:06 EST
Repeating from rdoinfo PR:

Python SDK for Cisco Ucs IMC doesn't seem to be directly openstack related, so we shouldn't need to maintain it in openstack-packages and chase its trunk.

How frequent are releases, would it be enough to rely on what's published on pypi?
Comment 3 Brian Demers 2016-01-22 13:30:27 EST
Yes, updates should be infrequent.  Whats on pypi is fine (that is what I used to submit the fedora package)

Ideally, we would just what gets packaged for fedora (on the EPEL branch), but this is a big of a knowledge gap for me.
Thoughts?
Comment 4 hguemar 2016-01-24 10:21:20 EST
I think we should just keep it in Fedora as it's a general-purpose lib.
I'll rebuild it in CBS.
Comment 5 hguemar 2016-01-24 11:00:50 EST
Ok, imported in CBS, I dropped the unused BR to python3-devel.
Since this is a new dependency, I tagged it straight to release.

Please reopen if it doesn't answer your question
Comment 6 Brian Demers 2016-01-27 12:35:50 EST
Works for me, but one more question.

How does/when the package get pushed to a repo that the delorean builds will pick up?
Comment 7 hguemar 2016-01-27 18:14:23 EST
If it's in CBS and Fedora, so it's already picked up by delorean

http://cbs.centos.org/koji/buildinfo?buildID=8296
http://koji.fedoraproject.org/koji/buildinfo?buildID=711044 <= this builds needs to be in stable (I pushed it)
Since there's no F22 build, I am rebuilding it into this copr builder but we'll be migrating delorean to F23 so less critical.
https://copr.fedorainfracloud.org/coprs/apevec/RDO-Liberty/build/156150/

Note You need to log in before you can comment on or make changes to this bug.