Bug 1301137 - rhnVirtualInstance uuid is not updated on system re-activation
rhnVirtualInstance uuid is not updated on system re-activation
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
570
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomáš Kašpárek
Jan Hutař
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-22 12:20 EST by Jan Dobes
Modified: 2016-03-22 13:12 EDT (History)
4 users (show)

See Also:
Fixed In Version: spacewalk-backend-2.3.3-38
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-17 09:51:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Dobes 2016-01-22 12:20:50 EST
Description of problem:
When your vmware guest changes it's uuid and you try to re-register it with rhnreg_ks using one time activation key, uuid is not updated.

Version-Release number of selected component (if applicable):
spacewalk-backend-*-2.3.3-33.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. Have registered virtual guest in Sat
2. Manually change it's uuid in rhnVirtualInstance table to see difference
3. reactivate the guest with one time key obtained on /network/systems/details/activation.pxt or via API 

Actual results:
the uuid value is not correct

Expected results:
the guest uuid value is updated
Comment 1 Jan Dobes 2016-01-22 12:37:41 EST
fixed in spacewalk master:

52e9b60c0e2d67c00f12d7897395143aeef47eb4
f3511f0fba540e2c89b427793cd43ed713ab5459
d446adee4a4b5988e1571bd70b19cca8f9d5bf8e
Comment 7 errata-xmlrpc 2016-03-17 09:51:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0461.html

Note You need to log in before you can comment on or make changes to this bug.