Bug 1301169 - router_delete_namespaces and dhcp_delete_namespaces should be enabled by default
router_delete_namespaces and dhcp_delete_namespaces should be enabled by default
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Hugh Brock
Eran Kuris
: TestOnly
Depends On: 1301167 1301170
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-22 13:46 EST by Brent Eagles
Modified: 2016-04-07 17:46 EDT (History)
4 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-7.0.3-1.el7ost.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1301167
Environment:
Last Closed: 2016-04-07 17:46:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Toni Freger 2016-01-24 07:38:31 EST
Please provide "fixed in version" information, in order us to start testing this bug.
Comment 3 Brent Eagles 2016-01-25 11:50:19 EST
Sorry, I specified the wrong package for fixed in version (it isn't a neutron issue, but a puppet/OSP-d one). I've updated the package to the relevant puppet module package where the default is set. I'm not 100% certain this is correct, because while the puppet modules is what has changed, verification entails ensuring that the heat templates used in a default OSP-d deployment do not alter the default values set by the puppet modules.
Comment 4 Eran Kuris 2016-01-26 02:13:13 EST
verified :
/etc/neutron/dhcp_agent.ini:# dhcp_delete_namespaces = True
/etc/neutron/l3_agent.ini:# router_delete_namespaces = True
[root@overcloud-controller-0 - ~]# rpm -qa |grep neutron
openstack-neutron-7.0.1-8.el7ost.noarch
python-neutron-7.0.1-8.el7ost.noarch
openstack-neutron-common-7.0.1-8.el7ost.noarch
python-neutron-lbaas-7.0.0-2.el7ost.noarch
openstack-neutron-openvswitch-7.0.1-8.el7ost.noarch
openstack-neutron-ml2-7.0.1-8.el7ost.noarch
python-neutronclient-3.1.0-1.el7ost.noarch

[stack@instack yum.repos.d]$ rpm -qa |grep -i triple
openstack-tripleo-0.0.7-1.el7ost.noarch
openstack-tripleo-heat-templates-0.8.7-2.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.2-1.el7ost.noarch
python-tripleoclient-0.0.11-5.el7ost.noarch
openstack-tripleo-common-0.0.2-4.el7ost.noarch
openstack-tripleo-image-elements-0.9.7-1.el7ost.noarch

[heat-admin@overcloud-controller-0 ~]$ rpm -qa |grep openstack-puppet-modules
openstack-puppet-modules-7.0.3-1.el7ost.noarch

created dhcp & router namespace and when delete router & network the namespaces deleted automatically
Comment 7 errata-xmlrpc 2016-04-07 17:46:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.