Bug 1301174 - unable to delete input in appliance_console
unable to delete input in appliance_console
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.5.0
All Linux
medium Severity low
: GA
: cfme-future
Assigned To: Nick Carboni
luke couzens
black
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-22 14:08 EST by Colin Arnott
Modified: 2016-11-29 11:31 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-29 11:31:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Arnott 2016-01-22 14:08:21 EST
Description of problem:
In appliance_console after text is entered it cannot be deleted and the backspace key generates ^H in the text input.

Version-Release number of selected component (if applicable):
5.5.0.13

How reproducible:
very

Steps to Reproduce:
1. run appliance_console
2. press enter and get to a text entry field
3. enter text
4. use backspace

Actual results:
^H character in inserted into text field

Expected results:
last character is deleted

Additional info:
Comment 2 Nick Carboni 2016-01-25 14:45:37 EST
I can't reproduce this in an ssh session (terminal + bash), through the vsphere thick client, or using VMM on fedora.  With what option in the appliance console are you seeing this behavior and how are you accessing the console?  I suspect this is an issue with that particular system rather than the console itself.
Comment 3 Colin Arnott 2016-02-09 16:13:37 EST
Sorry for the delay; I have reproduced the error and can confirm it is an issue with xterm specifically. Most Linux terminals emulate a VT200 terminal, but xterm targets VT100.

Let me know if this helps, or if you would like additional information.

Sources
0] http://ibb.net/~anne/keyboard.html#prob
Comment 5 Nick Carboni 2016-11-29 11:31:35 EST
Closing this as it is an issue with a specific terminal rather than a bug in the console.

Note You need to log in before you can comment on or make changes to this bug.