Bug 1301228 - [RFE] Support new event framework/connection handling improvements (Nunc Stans)
[RFE] Support new event framework/connection handling improvements (Nunc Stans)
Status: CLOSED ERRATA
Product: Red Hat Directory Server
Classification: Red Hat
Component: Directory Server (Show other bugs)
10.0
Unspecified Unspecified
high Severity high
: DS10.1
: ---
Assigned To: Noriko Hosoi
Viktor Ashirov
: FutureFeature, TestOnly
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-22 17:32 EST by Nathan Kinder
Modified: 2016-11-07 10:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-07 10:39:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan Kinder 2016-01-22 17:32:19 EST
Nunc Stans is an event framework wrapper that provides a thread pool for event callback execution. It provides thread safety to event frameworks by isolating and protecting the thread safe parts from the non-thread safe parts, and allows multi-threaded applications to use event frameworks that are not thread safe. 

Although the  ability to use a new optional event framework implementation was included in RHEL 7.2, it only received minimal QE testing.  

For RHEL 7.3, the requirement is for thorough scalability/performance testing with this new framework.
Comment 1 Noriko Hosoi 2016-02-10 13:07:59 EST
(In reply to Nathan Kinder from comment #0)
> Although the  ability to use a new optional event framework implementation
> was included in RHEL 7.2, it only received minimal QE testing.  
> 
> For RHEL 7.3, the requirement is for thorough scalability/performance
> testing with this new framework.

Does this bug for more complete testing for multi-threading or are there anything we should work on the nunc-stans code itself?
Comment 5 errata-xmlrpc 2016-11-07 10:39:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2665.html

Note You need to log in before you can comment on or make changes to this bug.