Bug 1301263 - TimedLogin option is not working in Red Hat Enterprise Linux 7.2
TimedLogin option is not working in Red Hat Enterprise Linux 7.2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gdm (Show other bugs)
7.2
All Linux
high Severity high
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
: Regression
Depends On:
Blocks: 1203710 1297830 1313485
  Show dependency treegraph
 
Reported: 2016-01-23 04:02 EST by Ashish Shah
Modified: 2016-11-04 02:40 EDT (History)
6 users (show)

See Also:
Fixed In Version: gnome-shell-3.14.4-40.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 02:40:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ashish Shah 2016-01-23 04:02:14 EST
Description of problem:

Auto login of user with TimedLogin options of gdm does not work after upgrade from RHEL7.1 to RHEL7.2
Problem is observed when dconf key /org/gnome/login-screen/disable-user-list is set to true

Version-Release number of selected component (if applicable):

Red Hat Enterprise Linux 7.2
gdm-3.14.2-12.el7.x86_64


How reproducible:
Always

Steps to Reproduce:

1. Add below entries in /etc/gdm/custom.conf file for auto login of user.

[daemon]
TimedLoginEnable=true
TimedLogin=USERNAME
TimedLoginDelay=10

2. Disable user list to configure banner message on gdm login screen.

# cat /etc/dconf/db/gdm.d/01-custom-gdm-settings
[org/gnome/login-screen]
disable-user-list=true
[org/gnome/login-screen]
banner-message-enable=true
banner-message-text='Corporate banner message text'

# dconf update


Actual results:

Auto login of user configured with TimedLogin option does not work

Expected results:

User configured for TimedLogin should automatically get logged in to the session. After logout from the session same user should automatically get logged in after the time configured in TimedLoginDelay is elapsed.

Additional info:

This was working well in rhel7.1 with gdm-3.8.4-32.el7.x86_64
Problem is introduced in rhel7.2 after re-base to gdm-3.14
Re-enabling user list is a workaround which does work to get timed login working on rhel7.2 But banner message configuration is not possible with this.
Comment 3 Ray Strode [halfline] 2016-04-20 16:33:59 EDT
should be set, marking MODIFIED
Comment 5 sgarciam 2016-08-10 06:44:52 EDT
Any extra information? Release date for the RHBA?
Comment 8 Michael Boisvert 2016-09-01 10:10:25 EDT
Timed log in is working on gnome-shell-3.14.4-52.el7 and gdm-3.14.2-18.el7.
Comment 10 errata-xmlrpc 2016-11-04 02:40:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2451.html

Note You need to log in before you can comment on or make changes to this bug.