Bug 130128 - (IT#42221) 64bit gdb install overwrites installed 32bit gdb
64bit gdb install overwrites installed 32bit gdb
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gdb (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elena Zannoni
Jay Turner
:
Depends On: 115047
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-17 08:28 EDT by Alexandre Oliva
Modified: 2015-01-07 19:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-31 11:05:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-08-17 08:28:25 EDT
1. Install gdb-6.0post-0.20040223.17.ppc.rpm for 32bit gdb 
2. Then install gdb-6.0post-0.20040223.17.ppc64.rpm for 64bit gdb 

The 64bit gdb can be installed without a problem but it overwrites the
32bit gdb.

I suppose if you remove the 64-bit gdb, you end up without any gdb
whatsoever, even though the 32-bit gdb package is still installed.

Since 64bit gdb can handle both 32bit and 64bit applications, why do
we need to 
have 32bit gdb?  And if we do need it for any reason, why don't the
rpms conflict, instead of silently eating each other, or use some
mechanism that enables both of them to be installed, say, install
gdb32 and gdb64, and have a shared gdb script that runs gdb64 if both
are available, and the only one installed otherwise?
Comment 2 Andrew Cagney 2004-08-23 11:18:35 EDT

*** This bug has been marked as a duplicate of 126853 ***
Comment 3 Alexandre Oliva 2004-08-23 17:05:34 EDT
Questions asked by customer not answered in the other bug.  Current
resolution is not good enough in that it doesn't solve the other
related bug, listed as a dependency of this one.  Reopening.
Comment 4 Elena Zannoni 2004-08-23 19:20:33 EDT
This is the behavior of rpm, not gdb. it prefers elf64 over elf32.
Besides, the 32 bit gdb should be overwritten, since the 64 bit gdb
for ppc can debug 32 bit binaries.
But they should use a more recent gdb. Also there have been fixes to
rpm to deal with packages installing multiple binaries.
What are they running? RHEL3 U3? If so, the gdb64 package has been
obsolete. They should now just have a binary named gdb which is elf64.

Comment 5 Alexandre Oliva 2004-08-23 20:43:04 EDT
I realize the base problem is in RPM.  That's why this bug depends on
the relevant rpm bug.

The bug was originally reported against RHEL3 U2, the latest released
update for RHEL3 at this time.  It was also tested on a U3 beta
available as of June 28.

They didn't ever mention the gdb64 package.  They mentioned ppc and
ppc64 gdb packages, and that, if you install both, one of the binaries
becomes permanently inacessible.  This is a bug.  You can't, for
example, compare the behavior of a 32-bit gdb with that of a 64-bit
gdb unless you take a copy of the 32-bit gdb.

Feel free to not act on this bug at all until the dependency rpm bug
is regarded as resolved.  The current approach is far from optimal.

That said, gdb could take the lead towards a reasonable solution and
install say gdb32 and gdb64 in the 32- and 64-bit packages,
respectively, and have gdb be a hard link, such that, whatever rpm
picks up by default, both binaries will still be available (as
expected).  Hopefully rpm will eventually take such a reasonable
approach (maybe not naming the files exactly like this, but something
along these lines).
Comment 6 Elena Zannoni 2004-08-24 08:47:40 EDT
Gdb cannot take the lead, because it needs to interoperate with RHN,
up2date, rpm, and there are other requirements besides this ibm "bug".
So I am closing this yet again. Tell them to run up2date and get the
new gdb.
Comment 15 John Flanagan 2004-12-21 14:37:19 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-561.html

Note You need to log in before you can comment on or make changes to this bug.