Bug 1301297 - Switch to systemd unit files
Switch to systemd unit files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sigul (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miloslav Trmač
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-23 15:41 EST by Kevin Fenzi
Modified: 2016-01-25 12:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-25 12:50:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Convert sigul to using systemd units (4.53 KB, application/mbox)
2016-01-23 15:41 EST, Kevin Fenzi
no flags Details

  None (edit)
Description Kevin Fenzi 2016-01-23 15:41:27 EST
Created attachment 1117485 [details]
Convert sigul to using systemd units

Soon FESCo has decided to drop all packages that still use sysvinit scripts. 

I've attached a patch that moves sigul to use systemd units instead of sysvinit scripts. Consider applying, or if you prefer I can go ahead and apply and build.
Comment 1 Miloslav Trmač 2016-01-25 12:50:34 EST
Thanks for the patch.

AFAICS those units couldn’t work:
* Starting services as the sigul user means they don't have enough privileges to open the log file, or create the pid file (nor to implement the unix-{user,group} directives from the config files).
* Type=simple along with -d means the service terminates as soon as the parent launches the daemon child.

I have now built sigul-0.102-2.fc24 with units that seem to work for me, though testing would be appreciated.

(systemctl stop takes 90 seconds to time out for each service, mostly due to #707382; but eventually systemd does terminate the daemons. The default timeout could very likely be tuned further, but this is good enough as a minimal conversion.)
Comment 2 Kevin Fenzi 2016-01-25 12:58:59 EST
Yeah, I meant to test, but ran out of time. ;) Sorry about that and thanks for fixing things up.

Note You need to log in before you can comment on or make changes to this bug.