Bug 1301322 - dnf search does not show if package is installed
dnf search does not show if package is installed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-24 01:00 EST by Niels Kobschätzki
Modified: 2016-01-25 08:28 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-25 08:28:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niels Kobschätzki 2016-01-24 01:00:07 EST
Description of problem:
FutureFeature
"dnf search" shows a list of packages as a result of the search. The list doesn't show which of the packages in the results are already installed.

Version-Release number of selected component (if applicable):
1.1.5

How reproducible:
Install a package with dnf and search for it

Steps to Reproduce:
1.dnf install "some package"
2.dnf search "some package"


Actual results:
A list of search results which includes the installed package without further information if it is installed

Expected results:
The package should have something like [installed] after its name or description

Additional info:
Comment 1 Michal Domonkos 2016-01-25 08:28:27 EST
By design, showing this kind of status is not in the scope of the search command.  To list the installed packages, please use the "dnf list installed" command instead.

Note You need to log in before you can comment on or make changes to this bug.