Bug 1301324 - Editing a Provider/Host Name with IP Address resets the value to the FQDN
Editing a Provider/Host Name with IP Address resets the value to the FQDN
Status: CLOSED DUPLICATE of bug 1301323
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Marcel Hild
Jeff Teehan
provider:host:web:ui
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-24 01:39 EST by Jeff Teehan
Modified: 2016-10-03 12:14 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 11:58:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: Unknown


Attachments (Terms of Use)

  None (edit)
Description Jeff Teehan 2016-01-24 01:39:36 EST
Description of problem:

I needed to set the Host Name to an IP Address rather than FQDN as the name doesn't resolve.  I also set the Default and Remote passwords (windows systems).  The password was wrong, so I went back in to change it, only now the IP Address had been replaced with the FQDN.  This further confused my test.

So, if a user sets the Host Name to be an IP address, we should not reset the value when editing the host.

Version-Release number of selected component (if applicable):
5.5.2.2 (verified with 5.5.0 as well)

How reproducible: It doesn't reset right away, but will after a few actions.  I'll polish up the steps.  It's not a big bug.


Steps to Reproduce:
1. Modify the Host Name field by editing a Provider/Host and use an IP Address.
2. Save the Changes
3. Navigate to Virtual Machines and then back to Hosts

Actual results:

The Host Name will reset back to the FQDN by itself.

Expected results:

The set value should be permanent.

Additional info:
Comment 2 Jeff Teehan 2016-01-28 13:18:24 EST
We'll have to work together on this.  The specific steps still allude me.  Hit me up when you want to do some troubleshooting.  I'm on IRC as jt
Comment 3 Marcel Hild 2016-02-11 15:18:31 EST
Is this a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1301323 ?
Comment 4 Marcel Hild 2016-02-22 04:30:27 EST
Jeff, if this is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1301323 can you please close this?
Comment 5 Jeff Teehan 2016-02-23 11:58:44 EST
Yes.  Closing now.  Added comments to the above bug.

*** This bug has been marked as a duplicate of bug 1301323 ***
Comment 6 Jeff Teehan 2016-10-03 12:14:27 EDT
Added Polarion test case

Note You need to log in before you can comment on or make changes to this bug.