Bug 1301340 - Error on removing Cinder disk snapshots
Error on removing Cinder disk snapshots
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high (vote)
: ovirt-3.6.3
: 3.6.3.1
Assigned To: Daniel Erez
Natalie Gavrielov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-24 06:20 EST by Daniel Erez
Modified: 2016-02-23 08:31 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 08:31:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tnisan: ovirt‑3.6.z?
rule-engine: planning_ack+
tnisan: devel_ack+
rule-engine: testing_ack?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 52654 master MERGED core: fix remove disk snapshots for cinder 2016-01-26 09:31 EST
oVirt gerrit 52762 ovirt-engine-3.6 MERGED core: fix remove disk snapshots for cinder 2016-01-27 09:06 EST
oVirt gerrit 52808 ovirt-engine-3.6.3 MERGED core: fix remove disk snapshots for cinder 2016-01-27 10:05 EST

  None (edit)
Description Daniel Erez 2016-01-24 06:20:16 EST
Description of problem:
Failure on removing a disk snapshot from Cinder storage domain
(see 'Additional info' for thrown error in the log).

Version-Release number of selected component (if applicable):
3.6

How reproducible:
100%

Steps to Reproduce:
1. Navigate to Storage main-tab
2. Select a Cinder Storage domain
3. Navigate to 'Disk Snapshots' sub-tab
4. Remove a disk snapshot

Actual results:
Operation fails.

Expected results:
Operation succeeds.

Additional info:
From engine.log - ERROR [org.ovirt.engine.core.bll.CommandsFactory] (org.ovirt.thread.pool-9-thread-40) [2393929d] Error in invocating CTOR of command 'RemoveDiskSnapshots': null
Comment 1 Red Hat Bugzilla Rules Engine 2016-01-24 06:20:19 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 2 Red Hat Bugzilla Rules Engine 2016-01-24 06:20:19 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 3 Red Hat Bugzilla Rules Engine 2016-01-24 06:22:43 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 4 Red Hat Bugzilla Rules Engine 2016-01-24 06:33:11 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 5 Red Hat Bugzilla Rules Engine 2016-01-28 07:10:45 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 6 Red Hat Bugzilla Rules Engine 2016-01-28 07:14:15 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 7 Red Hat Bugzilla Rules Engine 2016-01-28 07:18:38 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 8 Red Hat Bugzilla Rules Engine 2016-01-28 07:24:19 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 9 Red Hat Bugzilla Rules Engine 2016-01-28 07:29:20 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.

Note You need to log in before you can comment on or make changes to this bug.