Bug 1301352 - Point users of glusterfs-hadoop to the upstream project
Point users of glusterfs-hadoop to the upstream project
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: build (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Niels de Vos
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-24 07:18 EST by Niels de Vos
Modified: 2016-06-16 09:55 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:55:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niels de Vos 2016-01-24 07:18:14 EST
Description of problem:
We currently carry glusterfs-hadoop/ in the main glusterfs git repository. This is not the most up to date location were users should get the sources. There is the https://github.com/gluster/glusterfs-hadoop project where the sources and maintained.
Comment 1 Vijay Bellur 2016-01-24 07:28:30 EST
REVIEW: http://review.gluster.org/13286 (Point users of glusterfs-hadoop to the upstream project) posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)
Comment 2 Vijay Bellur 2016-01-30 07:53:36 EST
COMMIT: http://review.gluster.org/13286 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 2e69ae03c3c3fcb86e4d5347008834ad1dfb42b4
Author: Niels de Vos <ndevos@redhat.com>
Date:   Sun Jan 24 13:23:19 2016 +0100

    Point users of glusterfs-hadoop to the upstream project
    
    The code we have in glusterfs-hadoop/ is old and should not be used
    anymore. The plugin for Hadoop HCFS is maintained at the
    glusterfs-hadoop project on GitHub:
    
      https://github.com/gluster/glusterfs-hadoop
    
    Removing the old code from the repository, and adding a pointer to the
    projects wiki in the MAINTAINERS file.
    
    Change-Id: Ia86d08fb0c73a3f75b706b1e0793e3d7a0f4984c
    BUG: 1301352
    CC: Jay Vyas <jvyas@redhat.com>
    CC: Bradley Childs <bchilds@redhat.com>
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/13286
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 3 Niels de Vos 2016-06-16 09:55:37 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.