Bug 1301364 - virt-manager[760]: unhandled level 2 translation fault (11) at 0x00000000, esr 0x92000006
virt-manager[760]: unhandled level 2 translation fault (11) at 0x00000000, es...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
aarch64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-24 08:59 EST by Itaru Kitayama
Modified: 2016-10-03 07:29 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-03 07:29:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Itaru Kitayama 2016-01-24 08:59:36 EST
Description of problem:
Invoking virt-manager causes a level 2 translation fault

Version-Release number of selected component (if applicable):
virt-manager is part of f23

How reproducible:
100% of the time

Steps to Reproduce:
1. % sudo virt-manager
2.
3.

Actual results:
[   39.428224] virt-manager[760]: unhandled level 2 translation fault (11) at 0x00000000, esr 0x92000006
[   39.437420] pgd = fffffe03d6e10000
[   39.440802] [00000000] *pgd=0000000000000000, *pud=0000000000000000, *pmd=0000000000000000
[   39.449108] 
[   39.450595] CPU: 0 PID: 760 Comm: virt-manager Tainted: G        W       4.3.3-300.fc23.aarch64 #1
[   39.459524] Hardware name: AppliedMicro Mustang/Mustang, BIOS 1.1.0 Aug  4 2015
[   39.466803] task: fffffe00dbf3bb80 ti: fffffe00cc0cc000 task.ti: fffffe00cc0cc000
[   39.474285] PC is at 0x3ff8d8577c8
[   39.477687] LR is at 0x3ff8d8577c4
[   39.481081] pc : [<000003ff8d8577c8>] lr : [<000003ff8d8577c4>] pstate: 60000000
[   39.488448] sp : 000003fff0e12f20
[   39.491761] x29: 000003fff0e12f20 x28: 000002aac7cd70f0 
[   39.497091] x27: 000002aac77800a0 x26: 0000000000000000 
[   39.502400] x25: 000002aac7d9dda0 x24: 0000000000000000 
[   39.507701] x23: 0000000000000000 x22: 000002aac787b350 
[   39.513033] x21: 0000000000000000 x20: 0000000000000001 
[   39.518365] x19: 0000000000000000 x18: 000003ff8dcc1160 
[   39.523676] x17: 000003ff97b0b620 x16: 000003ff90a4fe00 
[   39.528999] x15: 0000000000000020 x14: 000002aac7d88170 
[   39.534331] x13: 000002aac7d88040 x12: 000002aac7d87ab0 
[   39.539640] x11: 0000000000000000 x10: 0101010101010101 
[   39.544942] x9 : 000003fff0e12d58 x8 : 0000000000000062 
[   39.550286] x7 : 0000000000000199 x6 : 0000000000000199 
[   39.555631] x5 : 000002aac78bbcb0 x4 : 0000000000000000 
[   39.560951] x3 : 0000000000000000 x2 : 000003ff90a50db0 
[   39.566262] x1 : 000002aac7d9e2a0 x0 : 000002aac7d9e2a0 
[   39.571563] 
[   52.520897] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
[   52.563452] tun: Universal TUN/TAP device driver, 1.6
[   52.568484] tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
[   52.703380] device virbr0-nic entered promiscuous mode
[   53.230320] nf_conntrack version 0.5.0 (65536 buckets, 262144 max)
[   53.561865] virbr0: port 1(virbr0-nic) entered listening state
[   53.567696] virbr0: port 1(virbr0-nic) entered listening state
[   53.728190] virbr0: port 1(virbr0-nic) entered disabled state

Expected results:
Fault should not happen.

Additional info:
Seen with the Mustang board.
Comment 1 Itaru Kitayama 2016-01-24 09:30:59 EST
Here's the kernel version 4.3.3-300.fc23.aarch64
Comment 2 Cole Robinson 2016-01-25 10:28:55 EST
Anything that generates a kernel trace like that is likely a kernel bug AIUI, so reassigning
Comment 3 Laura Abbott 2016-09-23 15:31:40 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.
Comment 4 Itaru Kitayama 2016-10-03 07:29:22 EDT
I've verified the command at least bring up its GUI if executed under the kernel 4.7.4-200.fc24.aarch64.

Note You need to log in before you can comment on or make changes to this bug.