Bug 1301366 - No VPN tab in Horizon after deploy OSP-7 with packstack - CONFIG_NEUTRON_VPNAAS=y
No VPN tab in Horizon after deploy OSP-7 with packstack - CONFIG_NEUTRON_VPNA...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Javier Peña
Ido Ovadia
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-24 09:18 EST by Eran Kuris
Modified: 2016-04-07 17:25 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-packstack-7.0.0-0.12.dev1699.g8f54936.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, Packstack did not enable the VPNaaS tab in the Dashboard even if the CONFIG_NEUTRON_VPNAAS parameter was set to 'y'. As a result, the tab for VPNaaS was not shown on the Dashboard. With this update, a check to see if VPNaaS is enabled has been set up. This check then enables the Dashboard tab in the Puppet manifest. As a result, the VPNaaS tab is now shown on the Dashboard when the service is configured in Packstack.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:25:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 269617 None None None 2016-01-29 15:37 EST

  None (edit)
Description Eran Kuris 2016-01-24 09:18:51 EST
Description of problem:
Deploy with latest packstack version OSP-7 and enabled VPNaaS in answer file 
CONFIG_NEUTRON_VPNAAS=y
deploy succuessful but there is no VPN tab in horizon .
The reason is packstack didnt change in :
/usr/share/openstack-dashboard/openstack_dashboard/local/local_settings.py

this parameter to "TRUE" 
OPENSTACK_NEUTRON_NETWORK = {
    'enable_distributed_router': False,
    'enable_firewall': False,
    'enable_ha_router': False,
    'enable_lb': False,
    'enable_quotas': True,
    'enable_security_group': True,
    'enable_vpn': False  <----------- this parameter should be change to True  
    'profile_support': 'None',
}


Version-Release number of selected component (if applicable):
[root@osp-7-packstack ~]# rpm -qa |grep vpn
openstack-neutron-vpnaas-2015.1.2-1.el7ost.noarch
python-neutron-vpnaas-2015.1.2-1.el7ost.noarch
[root@osp-7-packstack ~]# rpm -qa |grep packstack
openstack-packstack-2015.1-0.15.dev1589.g1d6372f.el7ost.noarch
openstack-packstack-puppet-2015.1-0.15.dev1589.g1d6372f.el7ost.noarch



How reproducible:
always
Steps to Reproduce:
1.Install OSP-8 with packstack , set VPNAAS = y 
2.after installation finish enter to horizon - no VPN tab 
3./usr/share/openstack-dashboard/openstack_dashboard/local/local_settings.py 
vpn is in false

Actual results:


Expected results:


Additional info:
Comment 4 errata-xmlrpc 2016-04-07 17:25:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.