Bug 1301385 - Search query returns wrong value for tag association
Search query returns wrong value for tag association
Status: CLOSED DUPLICATE of bug 1301383
Product: ovirt-engine
Classification: oVirt
Component: RestAPI (Show other bugs)
3.6.2
Unspecified Unspecified
unspecified Severity low (vote)
: ---
: ---
Assigned To: Juan Hernández
Pavel Stehlik
: Automation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-24 12:25 EST by Nelly Credi
Modified: 2016-01-25 04:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-25 04:46:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Nelly Credi 2016-01-24 12:25:23 EST
Description of problem:
If you have the same query, but expecting different result, 
the query may return wrong value
My example is on tags, where there is a host associated with it, but the query returns empty host list, but it maybe for other queries as well

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.create tag - tag_1
2.associate host with it
3.search - /api/hosts;max=-1;case_sensitive=true?search=tag=tag_*
4.de-associate
5.delete tag_1
6.create tag_2
7.associate host with it
8.search - /api/hosts;max=-1;case_sensitive=true?search=tag=tag_*

Actual results:
empty host list
<hosts />

Expected results:
the associated host

Additional info:
* If you query /api/hosts;max=-1;case_sensitive=true?search=tag=tag_2 it will return with correct search result

* it doesnt matter which API you use, you can start with rest & move to cli, but still the result will be the same - empty host list

* maybe there is some caching?
Comment 1 Gil Klein 2016-01-25 04:46:34 EST

*** This bug has been marked as a duplicate of bug 1301383 ***

Note You need to log in before you can comment on or make changes to this bug.