Bug 1301392 - intel video X freezes with 4.5.0
intel video X freezes with 4.5.0
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-24 13:26 EST by Kevin Fenzi
Modified: 2016-01-24 17:25 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-24 17:25:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2016-01-24 13:26:09 EST
Starting with (I think) kernel-4.5.0-0.rc0.git5.1.fc24 I have been getting "freezes" with X. The laptop is still up and working, just the display completely freezes and has no updates. Sometimes it recovers after 20 seconds or so, sometimes it does not. 

Logging in remotely I see no messages in dmesg or /var/log/Xorg.0.log that happen when the freezes do. Running 'chvt' remotely or hitting control-alt-lf3 or the like has no effect either. The only thing that seems to bring things back is doing a suspend/resume. 

Happy to try and debug if there's some way to gather more info. 

I will confirm which kernel it started on at least...
Comment 1 Kevin Fenzi 2016-01-24 14:49:40 EST
Confirmed that kernel-4.5.0-0.rc0.git1.1.fc24.x86_64 doesn't have the issue.

Will try others to isolate when it landed.
Comment 2 Kevin Fenzi 2016-01-24 17:25:23 EST
And after digging around some more and rebooting a bunch, it looks like this might have been a mesa bug. The update today seems to fix it up or at least make it much less likely. 

Sorry for the noise. :)

Note You need to log in before you can comment on or make changes to this bug.